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Disclaimer 
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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Example Item     Meaning 

View Perimeter a command name or a file that you are to select, including 
directory path 

Name: field name, button or icon in a dialog box 

Dialog Header dialog box name 

Tools > Options a command path that you are to select - usually from the 
pull-down menus 

Dialog Area heading for separated areas within a dialog box 

Tab heading for tabs found within dialog boxes 

Key in entering data with the keyboard or items selected from 
drop-down list 

Document name style used when referring to another document 

Note:  text  information about a command or process that you should 
pay particular attention to 

Concept:  text detailed definition of a concept, procedure or process 

Emphasis an important word or phrase 

Prompt user prompt 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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1. Getting Started 

Program Function 
Bentley Redline is the safe answer for engineering teams to assist in revisions 
throughout the entire design process without affecting the original drawing file  
(.DGN) file.  Bentley Redline provides multiple-function viewing, allows for 
comments and redlining, and has a print-to-scale feature that enhances the 
design and engineering data.  Bentley Redline offers user-friendly design review 
with annotation and printing tools for both .DGN and .DWG file content.  
Markups are easily managed and integrated into designs with clear 
communication to allow for an easy transition from markups to design changes. 

Course Overview 
In this course you will learn Bentley Redline® basics as they relate to CDOT 
projects. 

 Creating Redline design files 
 Learning the different components of the Redline environment 
 Creating basic elements in the design file (lines, circles, blocks, etc.) 
 Using view controls 
 Controlling graphic placement 
 Creating and working with groups of graphics 
 Placing text  
 Measuring elements 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project. 

http://internal/cadd/�
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CDOT Support Process 

Installation:  Call the CDOT Help Desk to request Redline installation at any 
time on any CDOT computer, before or after training, and without any 
prerequisites. 

However, before you call, check in "Start" on your desktop to see if Redline was 
installed by the IT department before your training.  Search for Start > All 
Program> Bentley Redline to verify installation. 

After a successful search, consider inserting a Redline icon on your desktop at 
this time.  See "Starting Redline" below for help with icons on the desktop.   

After training, follow the Instructions below to receive assistance on using 
Redline.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 Getting Started 

 

Bentley Redline Essentials  Page 15 

The CADD & Engineering Innovation website on the CDOT intranet is a 
valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, etc. One extremely 
useful link is to the Tips and Tricks section for MicroStation and InRoads. This information changes 
daily, so check back often. 
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CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized Redline workflows that CDOT has developed to 
assist you. These workflows are step-by-step CDOT-specific procedures for 
certain tasks that you may encounter when working in Redline on a CDOT 
project. Many of these workflows are referenced throughout the course. Some of 
the workflows are specific to working in MicroStation or InRoads software. 
Others may apply to both MicroStation and Redline. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 
New workflows are typically added with CDOT configuration updates, so check back often. 
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Configuration Questions/Suggestions 
Your Redline workspace configuration has been customized to CDOT standards.  
Each CDOT discipline group has provided input for items like standard symbols 
and details (cells), custom line types, discipline level structure, etc. 

As you work with this configuration in class and begin using Redline in 
production, you may have questions about the configuration or suggestions on 
how to make improvements.  For example, if you discover the need for 
additional levels or have a standard detail to include in the group’s library, you 
can provide suggestions to the CDOT Design/CADD Manager via the Request 
& Support link on the CDOT CADD & Engineering Innovation web page.  
Your CDOT CADD/Design Manager is: 

Helen Peiker 
Design/CADD Manager 
Project Development Branch 
4201 East Arkansas Ave., 4th Floor 
Denver, CO  80222 
303.512.5204 
Helen.Peiker@dot.state.co.us 

Your instructor was not involved in developing the CDOT Redline configuration 
and has no authority to make configuration changes. 
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Project Design Files 
When using Redline to mark-up existing drawings, Redline will automatically 
generate a new MicroStation file using the same root filename (JPC and 
standardized short description) as the file selected for marking up. This file will 
be stored in a folder titled ‘Redline’ in the project folder (see the following 
section on directory structure for clarification). The file created for storing 
Redline mark-ups will be appended with a unique extension. The file extension 
of this new file will correspond to the Windows User login name.  In this 
manual, files will have a *.cotrain01 extension as this is a representative User 
login name as may be used to log into a computer in a training environment.  

File Naming Conventions 
The CDOT naming standard uses a formula that restricts the character 
placement, ensures unique file names, and identifies the information contained 
in the file.  

All CDOT projects must follow these file naming conventions. Standardizing 
file names is necessary for effective management of the large numbers of files 
needed to produce a set of design plans. 

CDOT files are named in a standard format that identifies the file’s project, the 
data contained within it, and the product used for its creation. The naming 
convention is illustrated as follows: 

 

Job Project Code (JPC) is the CDOT project code, formerly known as the 
project sub account number. 

Specialty Group is the CDOT discipline code. 

Standardized Name is the defined names to describe the contents of the file. 

Annotation Scale is an optional field to define the scale set within the file. 

Description is an optional field to further define the contents and purpose of the 
file. 

Counter indicates more than one file of a specific type. 

File Extensions define the product used for its creation. Examples would be 
DGN for MicroStation, DOC for Microsoft Word, etc. 
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An example of a Redline file name follows: 

12345DES_Model.smithj 

12345 indicating the CDOT Project Number, DES_Model indicates it is 
Roadway Design’s design data file and smithj representing the users Windows 
login name. 
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Directory Structure 

Training Directory Structure 
All files related to this course are stored in the C:\Projects\12345\ folder, where 
12345 is the project code (JPC). Subfolders under the project contain the 
discipline-specific files. 

Project files follow a standardized scheme. This section describes the location of 
project files and the standard directory structure for each group within CDOT. 

Project Directory 
At the beginning of each project, the Project Manager will create a project 
directory structure using the CreatePrjDir.exe. This executable will create a 
directory that is the single storage location for all information pertaining to a 
given project. The Project Manager is required to assign access permissions to 
every person on the design team and is also responsible for maintaining the 
access list to keep it current. 

Top Level Directory 
Each project includes a unique top-level directory and a set of standardized sub-
directories. The job project code (JPC) indicates the top-level directory name. 

Group Sub-Directories 
Sub-directories for individual groups can be found below the top-level directory.  

Each group at CDOT that works on the project is required to store its data in the 
appropriate sub-directory for that group. 
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Group Sub-Directory Structure 
The following tables show the project directories for various groups and the file 
types that go into these directories.  These directories will be used regularly for the 
training course. 

Note: Refer to Appendix G for more information on the complete list 
of the project directory structure. 

Construction Project Folder (\Construction) 
Sub-directories Description     

\Calculations 

\Change_Orders 

\Claims 

\Correspondence 

\Diaries 

\Drawings Sheet Files - Plan set sheets and detail sheets 

\Cross_Sections All cross section Models and Cross Section 
*.job files 

\Reference_Files All final Model files to be referenced to the 
sheets 

\Tabs 

\EEO 

\Estimates 

\Final_Documentation 

\Photos Electronic photo files or scanned photos concerning the 
project and surroundings 

\Public_Relations 

\Speed_Memos 

\Working Design iterations and miscellaneous drafting without 
impacting final Model Files found in the 
Reference_Files subdirectory.  The designers’ initials 
should pre-fix all files in this directory so many 
designers can work in this directory. No working files 
should be used as Reference Models. When a working 
design is complete, copy it into the Reference_Files 
Folder and rename it to the standard naming convention.  
This directory will be deleted at project close-out. 
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Plot Sets Project Folder (\Plot_Sets) 
Sub-directories Description     

The files located in this folder are project specific General Plan Set Sheets. The 
files located in the subfolders will be files reflecting plan set sheets captured at 
time of submittal.  Final Plan Sets should be in Adobe Acrobat PDF file format 
for the Reproduction Department. The Reproduction Department will access the 
PDF from this location for submittals. 

\Plot_Sets 

 \AD Advertisement 

  \Revisions 

 \FIR Field Inspections 

 \FOR Final Office Revisions 

 \ROWPR 

Project Manager Project Folder (\Project_Manager) 
Sub-directories Description     

\Budget 

\Clearances 

\Contract_&_Task_Order 

\Correspondence 

 \Bridge 

 \Construction 

 \Design 

 \EEO 

 \Environmental_Landscape 

 \Governmental_Agencies 

 \Hydraulics 

 \Letters 

 \Materials_Geotechnical 

 \Public_Relations 

 \ROW 

 \Senior_Management 

 \Traffic 

 \Utilities 

\Meeting_Minutes 

\Schedules 

Redline Project Folder (\Redline) 
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Training Files 
Lab exercises direct you to use training files.  The most up-to-date training files for 
Redline are inserted onto your computer when Redline is installed.   

However, training files have changed considerably over time.  It might become 
necessary to reinstall the training files, especially if it has been several months since 
Redline was installed on your computer.  If in doubt or the Redline training files on 
your computer do not adequately match directions in lab exercises, reinstall the 
training files and download the latest version of this training manual. 

Installation icons for training files can be found on your Desktop Start Menu.  Exit 
from all Bentley Applications before installing the training files.  Select Start > All 
Programs > _CDOT_CADD_Information > Training Files > Insert Redline 
Training Files on my Computer.   

 

A link on the Training tab of the CADD & Engineering Innovation web site can 
also be used to install training files. This link and the start menu icon perform the 
same self-extract zip process to install training files on your computer. 

Lab Work 
It is highly recommended that you install the training file and continue practicing 
with Redline by completing the lab exercises contained in this course guide, 
especially if you do not plan to start work on a Redline project soon. 

This manual is set up for both Construction and Project Management therefore 
there are often two distinct lab files for these groups.  Construction lab files will be 
labeled Lab Xa while Project Management groups will be labeled Lab Xb.  Labs 
not specified with a letter after them are intended for both groups.  These group labs 
are less user specific and more fundamental to general software use.
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Mouse Mechanics 
There are three types of mouse “points” you can execute in Redline.  These 
points correspond to the different buttons on the mouse.  The default settings 
are: 

Mouse Points 
 

 

 

 

 

Data point   <D> — used to select tools and drop-down menus, identify 
coordinate locations, place and manipulate elements, or confirm/accept actions 
before they take place.  The left button is the default data button. 

Tentative point:  <T> — used to temporarily locate a point in space or a location 
on an element.  A tentative point can also be used to determine the coordinate 
value of an element or specific location.  The middle button (or wheel) is the 
default tentative button. 

Notes: To execute a tentative point on a two button mouse, 
simultaneously click the right and left buttons. 
If your mouse has a roller wheel, it can be used for zoom control. 

Reset:  <R> — rejects a highlighted element or rejects the current operation/tool 
(e.g. after placing a line in the drawing, the tool used to place the line remains 
active, so pressing the reset button will complete the command).  The right 
button is the default reset button. 

Using the Mouse 
Click — tap the mouse button once. 

Double click — tap the mouse button twice quickly. 

Snap — locate an existing point on an element by using a <T>, then <D> to 
accept. 

Controlling the Mouse 
By default, the left mouse button is the Data button, the right is the Reset and 
the middle is the Tentative.  You can change these button assignments by 
selecting Workspace > Button Assignments. 

 

Reset   <R>

Tentative   

Data   <D>
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Starting Redline 
To start Redline on the Windows platform: 

 From the desktop Start button, select  
Start > All Programs > Bentley Redline > Bentley Redline. 

or 

Double-click on the Bentley Redline icon (as a shortcut on your 
desktop).  

 

Note: Bentley software installations at CDOT do not insert icons on the 
desktop.  You must create shortcuts for Redline on your desktop.  
To do so, highlight the Bentley Redline icon from Start > All 
Programs > Bentley Redline > Bentley Redline, then right-
click on the Bentley Redline icon and from the fly out list that 
appears choose Send To > Desktop (create shortcut).  Then go 
to your desktop and Double-click on the Bentley Redline icon 
to start Redline.  

When Redline is started, the MicroStation Manager dialog box will appear on 
your screen. 
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MicroStation Manager 
The MicroStation Manager is your file management interface to Redline. 

 

By default, a MicroStation design file has an extension of .dgn.  “Design file” is 
a generic term used to describe all MicroStation files, regardless of their use.  In 
addition to MicroStation V8 DGN files, you can also open previous versions of 
MicroStation files and AutoCAD files (.dwg or .dxf).  To filter the various file 
types in a specific directory folder, change the List Files of Type option:   

 The CAD Files [*.dgn, *.dwg, *.dxf] option will display MicroStation 
and AutoCAD files.   

 The Redline Files [*.rdl] option will display only generic Redline files.   
 The All Files [*.*] option will display all the files that are located in the 

selected folder.  
 The *.cotrain01 option will display files that are specific to the user.  

This extension is based on the user login name.  The .cotrain01 
extension is automatically applied at the end of a file name when a 
Redline file is opened and a copy is made.  (Example:  When 
12345DES_TitleSht.dgn is opened from the 12345\Design\Drawing 
folder, a new file is created and saved in the 12345\Redline folder.  The 
new file that is made is given the user specific extension, 
12345DES_TitleSht.cotrain01).  The intent of this procedure is designed 
to allow all files located in the Redline folder to be sorted per specific 
user. 

Note: When a DWG file is opened in Redline, the new file will be 
given the extension _cotrain01.dwg. 

You can quickly access the last 10 files opened from the File drop-down menu.  
If a file is selected from the list, the file will automatically open. 
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In the Workspace category a User and Project can be selected.   

 The User workspace option sets the Redline environment to a predefined 
configuration.  There are two existing User options, CDOTRedline and 
CDOTViewonly.  CDOTRedline allows you to manipulate and modify 
graphics as needed.  The CDOTViewonly is a read-only option and 
allows only viewing, measuring, and plotting of graphics.  The 
CDOTRedline User option will be used for this training course. 

 The Project workspace option automatically sets the location and names 
of data files that are associated with a specific project.  The 12345 
Project option will be used for this training course. 
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To open a MicroStation design file: 
 Set the Project to your specific project code. 

 

 Navigate to the correct directory. 
 Set List of File Types to All files (*.*) (or to the type of file you wish to 

open.) 
 Click to highlight the file. 

 

 Click OK (or double-click the file name to open it directly). 

Note: MicroStation design files have a default extension of .dgn. 
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Thumbnail Previews 
When you select a file from the MicroStation Manager, a thumbnail preview of 
the file is displayed along with the type.  The four main types of previews you’ll 
see are: 

 The Bentley logo – represents a previous version (most likely V7 – it 
will list the version) design file. 

 

 Graphics image – represents a V8 design file. 

 

 A V8 logo – represents a converted V7 design file that has not been 
opened. 

 

 A DWG logo – represents an AutoCAD drawing file. If AutoCAD is not 
present, a generic logo as shown appears for .dwg files. 

 

Thumbnail images are captured when the save settings command is used.  
Redline can use a saved view called Preview for the image.  If this saved view 
doesn’t exist, the lowest numbered open window is used for the thumbnail.  

Thumbnail previews can also be viewed when in Windows Explorer.  Simply set 
the Window Explorer View display option to Thumbnails and any Redline files 
will be shown with their thumbnail image captured from Redline.  

Note: All AutoCAD files (.dwg extension) can be opened in Redline.  
However, the Redline format for an AutoCAD file is a .dwg 
format.  When a .dwg file is opened it creates the following file 
name, MainFileName_cotrain01.dwg.  So, if a master DWG 
file is opened in Redline, the file format will be in DWG file 
format. 
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The Redline Interface 

The Redline Screen 
 
 

 

 

 
 
 
 
 
 
 
 
 

 

Standard     Attributes       Primary         
tool bars (docked)

Tool Settings 

Main Tool frame  

Main Drop-down Menu 

View Controls 
View Groups 

Scroll Bars 

Select Tool/Prompts Information/ 
Messages 

Digital rights 

Active Level 
Locks 

Selection set 
Fence mode 

Workmode
Design change indicator 

Snap Mode 

CDOT Menu icon 

Title Bar 

Snaps 
Key-in Browser 
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The different parts of the Redline screen are: 

Drop-down Menus 

 

 Drop-down menus are used to access Redline toolbars, settings and 
dialog boxes. 

 An arrow next to a drop-down command indicates sub-menu options. 
 … Indicates a dialog box to open. 
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Toolbars 

 

 Redline’s tools for creating and manipulating your design elements are 
organized into logical groupings called toolbars. 

 Each tool is represented by an icon on its toolbar. 
 Toolbars can be opened, closed and moved around the screen like dialog 

boxes, views and the command window. 
 Toolbars can be “docked.”  

 

 Or “floating” within the drawing area. 

 

 Toolbars can be accessed from the drop-down menu or from the Main 
tool frame. 

Docked 

Floating 
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The Main Tool Frame 

                               

 The Main tool frame opens automatically when you start Redline.  If you 
close the Main tool frame and want to re-open it, select  
Tools > Main > Main from the drop-down menu. 

 

 The Main tool frame allows you access to other toolbars where most of 
your drawing tools exist. 

 To open a toolbar from the Main tool frame, <D> and hold on one of the 
tool icons and drag the pointer away from Main tool frame (floating the 
toolbar in the view window area). 

Delete Element 

Review Tags 

CDOT Menu 

Change Element Attributes 

Modify Element 
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CDOT Menu 
CDOT Menu basics: 

 Aides in increasing user efficiency. 
 Assists the user in adhering to standards. 
 Can be accessed by selecting the CDOT Menu icon on the top of the 

Main Tool frame. 

 

 The CDOT Menu dialog box can be resized as needed.  To do so, hover 
the pointer at a corner of the dialog until a double ended arrow appears.  
Left-click, hold, and drag to resize the dialog. 

 

The expanded CDOT Menu is shown below. 
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 The CDOT Menu contains four filters: Show Lines, Text, Cells, Pattern, 
and All.  When a filter is selected, items (drafting tools) that are specific 
for each filter appear in the selection window located below the filters.   

Show Lines Filter (As-Constructed): 

 

Show Text Filter (Mark-Ups): 

 

Show Cell Filter (As-Constructed): 
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Show Cell Filter (Mark-Ups):  No items available. 
Show Pattern Filter (As-Constructed): 

 

Show All Filter (As-Constructed): 

 

 When the All filter is selected, all of the available items are listed at the 
same time in the selection window. 
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 Selecting the Settings button from the lower left corner of the CDOT 
Menu dialog will open the Active Settings dialog.  An Active Scale 
and/or Active Angle can be changed from the Active Settings dialog.  

 

Drop-down menus 

Explorer
Window

Category

Status Window 

Filters 

Selection 
Window 

Item 

Cell Preview 
Window
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General Work Flow for operating the CDOT Menu: 

1. Select the Group Display menu pull-down option and choose the 
appropriate Group (Redline). 

2. In the Status portion of the dialog, Proposed is selected by default 
because Redline will not be used to add reviewer comments and 
construction mark-ups. It is not used to draw any existing features 
(such as topography).  

3. Select a Category As-Constructed (construction documentation) 
or Mark-Ups (reviewer comments). 

4. Select a Filter (Lines, Text, Cells, Pattern, or All) to simplify the 
selection of the appropriate tool. 

5. Select a specific drawing Item from the Selection Window to 
initialize the necessary drawing command. 

6. If needed, change the Active Scale or Active Angle from the 
Settings button to scale or rotate cells. 

 

  

  

 

Choose a Group 
from the Group 
Display option  

Choose a Status, Existing 
or Proposed 

Select a Category,
As-Constructed

or Mark-Ups

Select a Filter 

Adjust the Scaling or 
Angle option from the
Settings button 

Select an Item 
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Tool Settings 

     

 Many tools have parameters or settings associated with them, which are 
shown in the Tool Settings dialog box.  Each time you select a drawing 
tool, the optional settings will appear in the Tool Settings box.  The Tool 
Settings box is opened automatically when options exist for the selected 
drawing tool. 

 If it is desired to temporarily hide the Tool Settings box, the Popset 
feature can be enabled.  When Popset is enabled, the Tool Settings box 
is removed from the Redline viewing area.  To redisplay the Tool 
Settings box, hover over the active tool icon or hover over the Popset 
icon.  The Popset icon is located on the Primary Tools toolbar 
(discussed below). 

 

The Primary Tools Toolbar 

 

 The Primary Tools toolbar contains commonly used Redline tools, which 
will be discussed later. 

 This is one toolbar you’ll frequently use, so you will probably want to 
open and dock it. 

 Select Tools > Primary to toggle on the Primary Tools toolbar. 
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The Key-In Browser Box 

 

 Many Redline commands can be accomplished by keying in the 
command text (e.g. Change direction). 

 Key-ins can also be used to input data (e.g. xy=<x,y,z> to locate a 
coordinate). 

Note:  Key-ins are not case sensitive. 

 This is another method you can use to initialize drawing commands.   
Select Utilities > Key-in to open, and then dock the box. 

 The Key-in dialog box can be resized vertically and horizontally.  When 
resized vertically, additional data readout areas (Key-in Builder and 
Key-in History) are added to the bottom of the dialog box. 

 

 When you’re ready to key in a command, set the focus in the Key-in box 
by using the <D> (data) button. 

 After you key in the command, use the <Enter> key to activate the 
command or select the Run icon. 
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Views 

 

 The area where graphics are placed is called a view. 
 Up to eight view windows can be opened. 
 Open and close views from Window > Views. 

 

 Views can also be open and closed from the View Groups dialog box. 
This dialog box can be docked almost anywhere on your screen. A 
common location to find it is on the bottom of the drawing environment. 

 

 You can set different view perspectives (top, front, rotated, etc.) 
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 Opening Views 

 

A view or view window is the area in which you place graphics and view your 
design.  Up to eight view windows can be opened at one time.  You can open 
and close views from the Window > Views drop-down menu.  You can also 
select Window > Views > Dialog to open the View Groups toolbar where you 
can quickly turn views on or off. 

 

You can use the control buttons in the upper right-hand corner to maximize, 
minimize, or close a view. 

 

View Control Toolbar 
The View Control toolbar located in the lower-left corner of each view allows 
you to adjust what you see in that view and to maneuver around in the view.  
The horizontal and vertical scroll bars also help you move around in the view.  
To use the View Control toolbar and scroll bars, turn on the option Scroll bars 
on View Windows under Workspace > Preferences > View Options. 

 

Note:   Choosing Window > Tile will display all open view(s) in the 
viewing area with equal size. 

 View Groups toolbar 

View Control toolbar 
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Use the following View Control tools as follows: 

 Update View — to update a view (refresh or redraw). 

 

 Zoom In — to increase the magnification of a view by Zoom factor. 

 

 Zoom Out — to decrease the magnification of a view by Zoom factor (to 
see more of the design graphics). 

 

 Window Area — to increase the magnification of a view by drawing a 
“box” around the area you want to see close up. 

 

 Fit View — to show all displayable elements in a view. 

 

 Rotate View — to rotate the view (top, front, etc.) 

 

 Pan View — to move around in the view (up, down, right, left, etc.) to 
see other parts of the design without changing the magnification. 

 

 View Previous — to step back through view operations. 

 

 View Next — to step ahead through view operations. 
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Status Bar 

 

The Status Bar is Redline’s command center composed of the following areas 
(left to right): 

 Select Tool – displays the name of the active drawing tool and is located 
at the lower left corner of the screen. 

 Prompt – displays the next user operation needed by Redline. 

 

 

 

 

 

 Information and messages – displays current element parameter 
settings, error and other messages.  A data point <D> in this area 
activates the Message Center. 

 

 

 

 Snap mode – displays the active snap mode used in conjunction with a 
tentative point or AccuSnap. 

 Locks – displays a list of locks that you can quickly toggle on/off. 
 Active level – displays the current level on which graphics are placed.  

 

 

 

 

 

 

 

 

 Selection set – displays number of elements in the current selection set.  
A data point <D> in this area activates selection set commands. 

 Fence mode – displays the active fence mode setting.  A data point <D> 
in this area allows you to change the active fence mode. 

Select Tool Prompt 

Active level 

Locks 

Snap mode 
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 Workmode – a data point <D> in this area displays the current 
Workmode (e.g. DGN, V7, and DWG). 

 

 Design change indicator – a floppy icon indicates the file has been 
graphically modified. 

 Digital rights – displays if the file is protected for digital rights (user 
access control). 

 

 

 

 

 

 

 

 

 

 

Many of these concepts will be covered in later sections. 

Selection set 

Fence mode 

Design change indicator 

Workmode 
Digital rights 
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Show/Hide Toolbar Options 
You can select which tools you want to include on any toolbar.  This helps 
streamline your toolbars for the way you work and lets you customize your 
Redline setup.  

 

To show/hide tools, right-click on any toolbar and toggle the tools on/off as 
desired. 

Dialog Box Basics 

 

A dialog box can receive input from you or simply display information.  Most 
dialog boxes have to be closed before you can continue with other operations. 

A settings box refers to a special type of dialog box that can be left open on the 
screen while you work. 
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Dialog boxes can be moved anywhere in the Redline viewing area (click on the 
title bar and drag).  Tab or use the pointer to move between the following fields: 

Command Buttons — the active command button has a thicker black border 
(OK button). 

 

List box — List of items to choose with a mouse click <D>. 

Data entry box — used to key in information. 

 

Data entry box 

List box 

Options 

Check box 

Command buttons 
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Options — this is a drop-down list that contains a variety of choices. 

 

Check Box — a check box item is on if a check mark ( ) appears in the box. 
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 Lab 1 – Getting Started 

Objectives 
After completing this exercise you will know how to: 

 Start Redline. 
 Set the CDOT workspace. 
 Use the new CDOT directory structure. 
 Open a Redline design file. 
 Use the Redline mouse buttons. 
 Navigate the Redline interface. 
 Use the View Control commands. 
 Float and dock toolbars. 
 Show and hide tools on toolbars. 
 Access the key-in box. 

Note 
The text color was altered for ease of view. 

Starting Redline 
To start Redline: 

1. Select Start >All Programs > Bentley Redline > Bentley Redline. 

or 

Double-click on the Bentley Redline icon (as a shortcut on your 
desktop). 

 

Note: If the Bentley Redline icon is not located on your desktop as a 
shortcut, create it as a shortcut on your desktop.  To do so, 
highlight the Bentley Redline icon from Start > All Programs > 
Bentley Redline > Bentley Redline, right-click on the Bentley 
Redline icon, and, from the fly out list that appears, choose 
Send To > Desktop (create shortcut).   

Redline will start and the MicroStation Manager dialog box will appear 
on your screen. 
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The Redline Interface 

Working with Dialog Boxes  
Do not press <Enter> after you key data into a dialog box unless you are ready 
to apply the settings.  Use the <Tab> key or your mouse pointer to move from 
one field to the next to choose or enter your setup options before you Apply or 
OK the command. 

Open a design file 

 

1. In the Workspace section (lower portion) of the dialog box, set the 
options as follows:  

User:  CDOTRedline 
Project: 12345 

2. Set the Directory to:  
C:\Projects\12345\Design\Drawings\ (Double-click on C:\ 
then double-click on the Projects folder, etc.)  

3. Set List Files of Type to MicroStation DGN Files (*.dgn). 

4. Choose12345DESGenNote.dgn as the design file to open (place a 
data point <D> on the file name and it will highlight). 

A thumbnail preview of the file is shown.

1 

2 

3 

4 

5 
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5. Select OK to open the design file. 

Note:  After you open the MicroStation DGN file (in Redline), a new 
Redline file by the same name is created.  This file is 
automatically created and stored in the 
C:\Projects\12345\Redline directory.  Also notice that the 
new file was given an extension of .cotrain01.  You are now 
working in a new Redline file with the original DGN file as a 
reference.  This ensures that the original DGN file will not have 
any of its elements or text modified. 

 

A General Notes Sheet of the example project is opened. 
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Access Drop-Down Menus 
Use drop-down menus to select settings and non-drawing commands from the 
Redline interface.  You can either post a menu (display it until you select a 
function from the menu) or open the menu and select a command all in one step. 

Post a drop-down menu from the command window 

6. Move your pointer to the File option in the pull-down menu and 
select it by clicking the data point (<D>) once. 

 

 The drop-down menu appears. 
 Menu names followed by ... indicate a dialog box will open 

when you select the item. 
 Names with an arrow to the right indicate there is a sub-menu 

associated with the item. 
 Use the up and down arrow keys on your keyboard to move up 

and down an item list or move your pointer. 
 Text to the right of an item indicates the hot key or shortcut to 

use to activate the command (e.g., Ctrl+F means to hold down 
the Ctrl key and type F). 

 Underlined letters indicate a shortcut key to choose an item from 
a menu. 

7. Move your pointer to Element to show the drop-down menu 
options.  Take a minute to review the choices. 
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Open a Settings Box 
8. <D> the Locks icon from the Status Bar at the bottom of the 

Redline interface. 

 

 

 

 

9. From the popup menu, <D> on the Toggles option from the list.  
The Lock Toggles dialog will appear. 

 

Note: A settings box, like the Locks box, does not have any command 
buttons (OK, Close, etc.).  Settings boxes can be left open while 
working in Redline. 

 

10. Close the Locks settings box by selecting the X in the upper right 
corner. 

 

Locks 
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Control Views 
Zoom In command 

11. From the view control toolbar in View 1, select Zoom In. 

   

     

 

12. Make sure the Zoom Ratio option is set to 2 in the Tool Settings. 

 

13. Place your pointer (the X cross-hair) in the upper left corner of the 
sheet and place a data point <D>. 

The view is updated to Zoom In twice as close.  The center of the view is 
the data point you identified. 
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14. <D> one more time in the same location so that you can easily read 
the text. 

   

15. Reset <R> out of the Zoom In command. 
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Zoom Out command 

16. From the view control toolbar in View 1, select Zoom Out. 

17. Make sure the Zoom Ratio option is set to 2. 

 

The view is updated to zoom out twice as far. 

18.  <D> in the bottom right of the sheet to zoom out again until you 
can see the entire map. 
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Window Area command  

19. From the view control toolbar in View 1, select Window Area. 

 

 

 

20. <D> below and to the right of the project title text General Notes. 

21. <D> again below and to the right of the text (this will draw a box 
around what you want to show close-up). 
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The view is updated. 

 

View Previous command 

22. <D> on the View Previous command.  The previous view is 
displayed. 

 

Fit View command 

23. From View 1, select Fit View. 
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All of the graphics in View 1 are displayed in the view.   

Note:  If you are working in a drawing and cannot locate specific 
graphics, use the Fit View command.  This is a handy way to 
quickly display all the graphics inside of the view window. 

Closing a View 

24. Toggle off view 1 on the View Toggles box. 

   
 

 

Note:  You can also double-click on the B icon (the control menu 
icon) in the upper left corner of a view to close it or you can 
click the X icon in the view’s upper right corner. 
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Make view one fill the screen. 

25. Toggle on view 1 on the View Toggles box. 

26. <D> the Maximize button in the upper right corner of View 1. 

 

   

 

  

 

27. Select the Fit View command for View 1. 

 

 

Minimize view 
  Maximize view 
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Practice Relocating Toolbars 
Undock a toolbar from the Main tool frame. 

28. <D> on the Place SmartLine icon from the Main tool frame to 
display the Linear Elements toolbar. 

29. Hold down the data button <D> and drag your pointer to the right 
until the toolbar is free from the main tool frame. 

 

30. Release the data button when the temporary toolbar outline is at 
the desired location. 

 

31. Select the Place SmartLine command. 

 

  

32. Select the Place Point or Stream Curve command from the 
Linear toolbar and notice the changes in the Tool Settings box. 

Hold down the 
data <D> button  

and drag 

Release the data 
button and the tool 

bar is undocked 

Tool Settings for 
Place SmartLine 
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Note:  Tool Settings dialog appears and updates for each tool selected. 

33. Close the Linear toolbar by clicking the Close icon ( ) in the 
upper right corner. 

Tool Settings for Place 
Point or Stream Curve 
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Float and Dock Toolbars 
 Float the Primary Tools toolbar. 

34. Position your pointer over the left edge of the Primary Tools 
toolbar at the top of the Redline interface. 

35. Hold down the data button and drag the toolbar until it “floats” in 
the view. 

 

 

36. Repeat the steps to float or undock the Standard toolbar. 

 

Toggle the Primary Tools toolbar off/on. 

37. Select Tools > Primary. 

The Primary Tools toolbar is turned off. 

38. Select Tools > Primary again to toggle it back on. 

39. Dock the Primary Tools toolbar back to the upper right corner of 
the Redline interface by dragging the title bar with the data button. 

Note:  Any toolbar can be docked on the perimeter (top, bottom, left or 
right sides) of the Redline interface.  

 

Hold down the data <D> button and drag 
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Show/Hide Tools 
40. Locate the floating Standard toolbar. 

  

41. Right-click anywhere on the Standard toolbar.  In the list of tools, 
toggle off Save. 

 
Note:  Redline files are automatically saved back to the disk drive. 

The Save tool is removed from the toolbar. 

 

42. <R> and choose List. 

 

43. Toggle off the Cut, Copy, Paste, and MicroStation on the Web 
options. 
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44. Choose OK. 

 

The toolbar is updated to show these tools hidden. 

 

45. <R> and select Show All. 

 

All tools are now shown on the toolbar. 

46. Dock the Standard toolbar back to the upper right corner of the 
Redline interface by dragging the title bar with the data button. 

Note: Use this procedure to customize any toolbar to show just the 
tools you want to use. 
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Using the Key-In Box 
Open and dock the key-in box. 

47. By default, the Key-In box is docked at the bottom of the Redline 
interface.  Float the Key-in box from the bottom of the screen.  If 
the Key-In box is not open, select Utilities > Key-in to open it. 

 

48. Expand the undocked box by grabbing the bottom of the box and 
dragging down when the double ended arrow appears.  An 
expanded box can be made smaller to maximize available space.  
To do so, use the same double ended arrow that is used for 
expanding the box.  

 

Key-ins can be selected from the list, but are typically just typed directly 
into the box. 

  

Key-in Field 

Key-in Builder 

Key-in History 
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49. Grab the title bar of the key-in box and drag it to the blank space at 
the bottom of the Redline interface to dock the box.   

 

 

 
 

The Key-in box docks beside the other toolbars in the Redline interface. 

Save settings in the file so the views will look the same when you next open 
the design file. 

50. In the Key-in box you just docked, place a data point to set the 
focus in this box (you will get a blinking cursor). 

51. Key in File (short for File design), then press <Enter> on the 
keyboard. 

Note: When using key-ins, you always need to press <Enter> to initiate 
the key-in that was entered.  

Keep the Key-in box docked.  It is where you will key in all Redline 
commands. 

Note: To Save Settings you could also select File > Save Settings or 
press Ctrl+F on your keyboard.  Most commands can be 
accomplished with either key-ins or by selecting from the menu 
or toolbars. 

By saving settings, the next time you enter this design file, it will be 
exactly as you left it. 

52. Choose File > Exit to exit Redline and your design file. 

Key-in Docked 
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Using the Undo and Redo Commands 
When you delete an element, it is moved to the Undo buffer.   Redline 
remembers everything that is placed in the design file even after it’s gone.  You 
can retrieve a deleted element using the Undo command (Edit > Undo).  The 
Redo command (Edit > Redo) negates the last Undo command. 

The Undo and Redo commands not only work on deleted elements, but on most 
graphics commands.  For example, you can place a line, use Undo to remove the 
line, and then use Redo to re-place the line. 

The Undo buffer is virtually unlimited in size (it’s only limited by the operating 
system file size limit). 

The Undo and Redo commands can also be accessed from the Standard toolbar 
(Tools > Standard). 

 

Note:  Exiting the design file clears the Undo and Redo buffer. 
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2. Design File Basics and Element Placement 

Coordinate Readout 

Coordinates and Angles 
Use Settings > Design File > Coordinate Readout to determine how Redline 
values are displayed.  This is helpful, for example, when you measure graphics.  
You can set the display values to read out in master units (e.g. feet), sub units 
(e.g. inches), or both (e.g. feet : inches).  Angles can be displayed as either 
degrees-minutes-seconds (DD MM SS) or decimal degrees (DD.DDDD) with up 
to 8 decimal place accuracy. 

 

Entering Data 
When entering data for any lengths or distances, use the format for working 
units: MU:SU.  You can enter data in just master units, just sub units, or both. For 
example, if your working units are 1:12 (feet and inches), and you want to place 
a line with a length of 1 foot 1 ½ inches, you could enter the length as: 

 1.125 
 1:1 1/2 
 :13 1/2 

Note:  You can use either fractions or decimals when entering data. 
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Angle Modes 
You can set the angle Mode to Conventional, Azimuth or Bearing. 
Conventional angle mode sets 0 degrees at the horizontal (East) and positive 
angles are measured counterclockwise. 

 

 

 

 

 

 

Azimuth angle mode sets 0 degrees at the vertical (North) and positive angles 
are measured clockwise. 

 

 

 

 

 

 

Bearing angle mode measures angles based on direction.  This is the default 
angle mode in Redline and CDOT’s standard mode. 
 

 

 

 

 

 

 
Graphics can be drawn with one angle mode and read with another.  You can 
switch angle modes and formats as much as you like under Coordinate 
Readout without affecting your graphics. 
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Basic Element Commands 
The following toolbars contain basic commands for creating elements such as lines, 
circles, blocks, and arcs.  These common tools are shown below with their Tool 
Settings box options. 

Notes:        Any of the closed elements can be filled for shading. 

A <D>, a key-in, or a snap can specify any location for 
placement of an element. 

Selecting the As-Constructed category establishes both the 
commands and the appropriate levels for placing 
construction notations. As you will see in the following lab 
(2b) selecting the Mark-ups category offers additional 
options for modifying, adding, noting a deletion, or 
requesting a check of particular items while plans are in the 
review process. 

Linear Elements Toolbar 

      

Place SmartLine 
Activated from the CDOT menu – The Place SmartLine tool is the default tool 
that becomes active when the Linework item is selected from the CDOT menu.  
To use place SmartLine, open the CDOT menu from the main tool frame, set 
your filter to Show Lines, and choose the Linework item.   

Smart Line places a chain of connected elements consisting of lines and/or arcs.  
The resulting graphic is one connected element.  You can create sharp or 
rounded corners between the linear elements. 
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Place Point or Stream Curve 
Points Method – Places a Redline curve through points identified in the view. 

Stream Method – Places a continuous line based on the movement of the 
pointer.  Largely used for digitizing or free handing contours. 

 

Polygons Toolbar 
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Place Block 
Places a block (square or rectangle, not to be confused with an AutoCAD block) 
using two methods: 

 Orthogonal — specify the opposite corners of the block or 
 Rotated — specify a baseline angle, then the diagonal corner.   

 

Note: This command has no relation to the term “block” in AutoCAD.  
They are two completely different concepts.  In Redline, a cell is 
the equivalent of an AutoCAD block. 

Place Shape 
This command is used to place an irregular shape (closed element).  You can 
draw the shape (data point to data point) or you can specify the length or angle 
of each shape segment.  Use the Close Element option for the last point to 
ensure closure. 

    

Place Regular Polygon 
Places a 3-4999 sided shape where all sides are equal in length by any of these 
three methods: 

 Inscribed — polygon is placed inside of an imaginary circle. 
 Circumscribed — polygon is placed outside of an imaginary circle. 
 By Edge — the length of one side is defined by the user graphically. 
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Ellipses Toolbar 

 

Place Circle 
Places a circle by one of three methods: 

 Center — specify the center location and a point on the circle.  A radius 
or diameter can also be specified. 

 Edge — specify three edge points.  
 Diameter — specify two points to define the diameter. 
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Place Ellipse 
Places an ellipse by one of two methods: 

 Center — specify two points for the primary axis and a third point for 
the secondary axis. 

 Edge — specify three edge points. 

You can specify constraints — the Primary and Secondary axes and the 
Rotation angle.  A location is all that is needed to then place the ellipse. 

 

Place Arc 
Places an arc by two methods: 

 Center — specify an arc endpoint, center point and sweep angle for the 
other endpoint. 

 Edge — specify three points: an endpoint, a point on the arc and the 
other endpoint. 

     

Arcs can be placed either clockwise or counterclockwise. 

The arc radius, length, start angle, or sweep angle can be constrained to help 
you place the arc.  A positive length places the arc counterclockwise, a negative 
length places the arc clockwise. 
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Deleting Elements 
To delete an element: 

 Choose the Delete Element command from the Main tool frame. 

 

 Move your pointer over the element and <D> anywhere on it to identify 
the element for deletion (it will highlight). 

 <D> to accept the deletion. 

Note: Choose Element Selection or another tool to get out of the 
Delete command. 
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Lab 2a – Placing Elements into the Drawing 
(Construction Group) 

Objectives 
After completing this exercise you will know how to: 

 Place a line. 
 Place a circle. 
 Place a block. 
 Delete an element. 

Use various Drawing Tools 

Open the Design File 
1. Start Redline and open 12345DES_PnP01.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

Use the Place SmartLine Command  
2. Window or Zoom into a blank area on your screen where graphics 

are not present. 

3. Activate the CDOT Menu from the Main Tool frame. 

 

4. Resize the CDOT Menu dialog if necessary. 

5. From the CDOT Menu, select the As-Constructed category. 

6. Select the Show Lines filter. 

7. Then select the Linework item. 

8. Look at the Linear toolbar, notice that the Place SmartLine 
command was automatically selected as the active command.   
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9. Look at the Attributes toolbar, the active symbology was also 
automatically selected for you (active level, color, line weight, 
etc.). 

 

10. Verify that the Tool Settings Segment Type is set to Lines. 

 

11. <D> anywhere in the view window area to define the starting point 
of the line. 

12. Move the pointer to another location and <D> to define the end of 
the line. 

13. <R> to complete the command. 

A line is placed in the drawing. 

 

14. Follow the same steps (steps 11-13) to place another line in the 
drawing. 
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Use the Place Block Command 
15. Verify that the Linework item is still selected from the CDOT 

Menu.  By having the Linework item selected, the correct level and 
symbology are defined. 

 

16. Select the Place Block command from the Polygons toolbar. 

Note: It is required to select the Place Block command because the 
Place SmartLine command is always the default active 
command when a Linework item is selected. 

  

17. Set the Method to Orthogonal. 

 

18. <D> anywhere in the view window area to define the starting point 
of the block. 

19. Move the pointer to another location and <D> to define the 
opposite corner of the block. 
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Use the Place Circle Command  
20. Verify that the Linework item is still selected from the CDOT 

Menu. 

21. Select the Place Circle command from the Ellipses toolbar. 

 

Note: It is required to select the Place Circle command because the 
Place SmartLine command is always the default active 
command when the Linework item is selected. 

22. Set the Method to Center. 

 

23. <D> anywhere in the view window area to define the center of the 
circle. 

24. Move the pointer to another location and <D> to define a point on 
the circle. 
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Use the Delete Element Tool  
25. Select the Delete Element tool from the Main Tool Frame. 

 

26. Hover the pointer over any element and <D> to identify it for 
deletion. 

 

27. <D> again (anywhere in the view window) to accept the element 
for deletion. 

28. Practice deleting other elements on your own. 
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Lab 2b – Placing Elements into the Drawing  
(Project Management Group) 

Objectives 
After completing this exercise you will know how to: 

 Use a variety of mark-up items. 
 Place a line. 
 Place a circle. 
 Place a block. 
 Delete an element. 

Use various Drawing Tools 

Open the Design File 
1. Start Redline and open 12345DES_PnP01.dgn from the 

C:\Projects\12345\Design\Drawings\ folder (this is the same 
file that was used for the previous lab, Lab 2a, so this file may 
already be open if you completed Lab 2a). 

Use the Place SmartLine Command  
2. Window or Zoom into the area shown. 
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3. Activate the CDOT Menu from the Main Tool frame. 

 

4. Resize the CDOT Menu dialog if necessary. 

5. From the CDOT Menu, select the Mark-Up category. 

6. Select the Show Lines filter. 

7. Select the Color Green (Add) item. 

 

8. Look at the Linear toolbar, notice that the Place SmartLine 
command was automatically selected as the active command.   

 

9. Look at the Attributes toolbar, the active symbology was also 
automatically selected for you (active level, color, line weight, 
etc.). 

 

10. Verify that the Tool Settings Segment Type is set to Lines. 

 



 Design File Basics and Element Placement 

Bentley Redline Essentials  Page 85 

11. <D> near the existing power line to define the starting point of the 
line (indicated by an X). 

12. Move the pointer and <D> to define the end point of your added 
power line (indicated by an X). 

13. <R> to complete the command. 

A line is placed in the drawing. 
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Use the Place Circle Command  
14. Verify that the Color Green (Add) item is selected or reselect it 

from the CDOT Menu to ensure that the correct level and 
symbology are applied to indicate an added item. 

15. Select the Place Circle command from the Ellipses toolbar. 

 

Note: It is required to select the Place Circle command because the 
Place SmartLine command is always the default active 
command when the Linework item is selected. 

16. Set the Method to Center. 

17. Set Fill Type to Opaque. 

18. Enable the Diameter setting by <D> in the check box. 

19. Enter a Diameter of 4.9 and press Enter.The dialog box should 
look like the following: 

 

20. <D> near the newly added line to indicate position of new electric 
pole. 
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Use the Place Block Command 
21. Choose Color Yellow (Check) item from the CDOT menu.  This 

will ensure that the correct level and symbology are applied to 
your block to indicate an item to be checked. 

 

22. Select the Place Block command from the Polygons toolbar. 

Note: It is required to select the Place Block command because the 
Place SmartLine command is always the default active 
command when the Linework item is selected. 

  

23. Set the Method to Orthogonal. 

24. Set Fill Type to None. 

 

25. <D> towards the upper left corner of your recent additions 
(indicated by an X). 
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26. Move the pointer to the lower right and <D> to define the opposite 
corner of the block and define the area to be modified (indicated by 
an X). 

 

Use the Delete Element Tool  
27. Select the Delete Element tool from the Main Tool Frame. 

 

28. Hover over any of your recent additions and <D> to identify it for 
deletion. 

29. <D> again (anywhere in the view window) to accept the element 
for deletion. 

30. Practice by deleting remaining additions on your own. 
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3. Element Selection and Manipulation 
There are times when it is necessary to group elements because it is more efficient 
to place, modify, or manipulate groups of elements rather than perform repetitive 
commands on individual elements.  If you want to perform a one-time manipulation 
on a group of elements (e.g.. copy or delete them), create a selection set or use a 
fence to group the elements. 

Element Selection Toolbar 

 

The Element Selection toolbar provides various methods for temporarily 
grouping elements.  Once grouped, elements can be modified, manipulated or 
deleted as a group.  When elements are grouped with these tools, they are placed 
in a selection set and remain in the selection set until you clear the set. 

Elements are highlighted upon entry into a selection set.  You can change the 
selection set color under Settings > Design File > Color > Selection Set Color.  
You can also quickly see the number of elements in the selection set from the 
indicator on the Status Bar. 
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Element Selection 
Selects individual elements and adds them to the selection set in the Redline file. 

 

Notes:  Selected elements are indicated by color highlighting.  

Elements in a referenced file may or may not be selectable based 
on the status of the References locate option, whether it is toggled 
on or off.  

The status of the locate option determines whether elements in a 
referenced file can be copied into the active drawing. Copy is the 
only manipulation command allowed on referenced graphics. 

Referencing is discussed in more detail in Chapter 6 

 

To add an element to a selection set: 

 Select the Element Selection command. 
 <D> on the element. 

Handlebars appear on the element and it highlights. 

To add multiple elements to the set 

 Select the Element Selection command. 
 Hold down the data button and drag across the elements to add (drag 

corner to opposite corner in a rectangular area). 

All elements placed in the set highlight. 

To add additional elements to the set: 

 Hold down the <Ctrl > key. 
 <D> on the element to add. 

The element highlights. 

To remove an element from the set: 

 Hold down the <Ctrl > key. 
 <D> on the element currently in the set. 

The highlight is removed and the element returns to it original color. 

To clear the selection set: 

 Select the Element Selection command. 
 <D> in any “clear” area in your view. 
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Manipulate Toolbar 

 

The Manipulate toolbar commands (copy, move, etc.) allow you to manipulate an 
entire element.  Follow your prompts closely to properly execute the commands.   

Copy Element  
The Copy command makes a copy of one or more existing element(s) and 
allows you to position the copy as desired. 

     

To copy an element: 

 Select the Copy command. 
 <D> on the element to identify it. 
 <D> to identify the location for the copy. 

Note:  You can also identify the element for modification (using the 
Element Selection command) and then select the Copy 
command. 

Move Element  
The Move command moves an element from one location to another. 

     

To move an element: 

 Select the Move command. 
 <D> on the element to identify it. 
 <D> in the new location to position the element. 

Note:  You can also identify the element for modification (using the 
Element Selection command) and then select the Move 
command. 
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Manipulating Multiple Elements 
The tools in the manipulation toolbar can also be used on multiple elements at 
once. 

To manipulate multiple elements: 

 Create a temporary selection group using the element selection tool. 
 Select the desired manipulation command from the manipulate toolbar. 
 <D> on an element in the selection set to identify the group. 
 <D> in the new location to position the elements. 

Modify Element 

  

The Modify command allows you to change the geometry of an existing element 
(e.g. shorten, lengthen, move the location of vertices, etc.).    

To modify an element: 

 Select the Modify command. 
 <D> on the element to identify it. 
 <D> at the location in which you would like to modify the element to 

(shorten, lengthen, etc.). 
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Lab 3 – Element Selection and Manipulation 

Objectives 
After completing this exercise you will know how to: 

 Group elements using the Element Selection command. 
 Copy elements. 
 Move elements. 
 Modify elements. 

Select and Manipulate Elements 

Open the Design File 
1. Open 12345DES_PnP18.dgn from the 

C:\Projects\12345\Design\Drawings\ folder (this file may still 
be open from the last lab). 

Place Lines 
2. Zoom into the area below (top-center of the sheet). 

 

3. Activate the CDOT Menu from the Main Tool frame if it isn’t 
already activated. 

4. From the CDOT Menu, select the Show Lines filter. 

5. Then select the Linework item. 

The Place SmartLine command is selected. 

 

6. Set the Settings options as shown. 



Colorado Department of Transportation 

 

Page 94  Bentley Redline Essentials 

 

7. “X” out one tree as shown below. 

  

 “X” out the tree 
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Place Text 
8. From the CDOT Menu, select the Show Text filter. 

9. Select the .07 Const-100 Text item. 

The Place Text command is selected. 

 

10. Set the Settings options as shown. 

 

11. In the Text Editor-Word Processor, key in the text below.  Where 
indicated press the <Enter> key to shift text to the next line. 

TREE <Enter> 
REMOVED 

 

12. <D> next to the “X” to place the text. 

  

Place the text here
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Use the Element Selection Command 
Create a selection set of the redlines 

13. Select the Element Selection command from the Element 
Selection toolbar. 

 

Place a selection box around the “X” and text.  

14. <D>, hold, and drag the pointer. 

15. Release the data button once the selection set boundary 
encompasses the lines and text as shown. 

 

The selection set field on the status bar should show that three elements are 
currently selected.  Notice that the tree element was not included in the selection 
set.  This is because the Reference ‘locate’ option is off by default (Referencing 
is discussed Chapter 6).  

 

 

Start here

Release the mouse 
button here 
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Copy Elements 
16. With the three elements still selected, pick the Copy command 

from the Manipulate toolbar. 

 

17. <D> a point on or near the selection set, DO NOT accept. 

18. Move your pointer over another tree as shown below and <D> to 
accept the placement. 

  

19. Using the same procedure, make another copy and place the 
graphics as shown. 

  

Copy here 

Copy here
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Move Elements 
Deselect the “X”.  

20. Select the Element Selection command. 

 

21. Press and hold the [Ctrl] key. 

22. <D> on one line and then the other. 

The text should now be the only element selected.   

 

 

23. Select the Move command from the Manipulate toolbar. 

 

24. Set the Settings options as shown. 

 

25. <D> a point on or near the selection set. 

Text is selected
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26. Move your pointer and <D> to place the text approximately as 
shown. 

 

27. Move the other text to the right so that the graphics appear as 
shown. 

 

28. Clear the selection set by clicking anywhere in the drawing (with 
the Element Selection command active). 

Move here 
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Modify Elements 
29. Window into the area in which you placed a culvert from the 

previous chapter (the culvert placed for the Construction Group, 
Lab 3a, will be shown below). 

 

30. Select the Modify command. 

 

31. <D> on one end of the culvert as shown. 

 

32. Move the pointer to the left approximately as shown and <D> to 
relocate (modify) the end of the culvert. 

Modify this end 
of the culvert 
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33. <R> to complete the modification operation. 

 

 





 Text 
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4. Text 

Text Toolbar 
The Text toolbar is used to place and edit text.  When you place text, you specify 
a style to apply to the text. 

 

Place Text 
Activated from the CDOT menu – There are two items available when the 
Show Text filter is selected.  One is the Place Text tool and the other is the Place 
Note tool.  The Place Note tool is detailed in the next section.  To use the Place 
Text tool, open the CDOT menu from the main tool frame, set your filter to 
Show Text, choose the desired Place Text item (items with a corresponding “A” 
icon).  The Place Text tool places text in the drawing based on the text that is 
entered into the Text Editor — Word Processor window.  The Redline Text 
Editor uses some basic word processing format options (font, bold, underline, 
italics, etc.), which allows for quick text manipulations.   
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Information about CDOT text styles 
Text Styles provide a method of saving and applying text attributes in 
MicroStation.  They function similar to styles used in word processing software, 
saving text setups that include font, height and width, line spacing, color, etc. 
When you apply a style, it’s like applying a whole set of characteristics in one 
step.  Once the style is applied, the text is linked to the style and any future 
changes to the style will update all text currently using the style.  The text style 
contains attributes like font, height, width, line spacing, line length, text 
justification, etc. 

CDOT text styles are categorized by text size (e.g. .07”, .10”, .14”, etc.)  Each 
style is one of two types – 100 or 80 (e.g. .07” Const-100). 100 styles have the 
same text height and width. 80 styles are proportional sized – the text width is 
80% of the text height.  

 

Text is placed using active text and design file parameters including: 

 Active element symbology (color, weight) 
 Active level 
 Active angle and 
 Text style. 

Place Text 
items using 
defined CDOT 
text styles 
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Text placement methods 

 

When you place text, choose one of the following methods for how the text is 
applied:  

 By Origin uses active style or text settings (size, font, justification, etc.) 
and active element settings (AA, CO, WT, LV). 

 

 Fitted uses two data points to define the active size, spacing and angle of 
the text  (the text fits between the two points). 

 

 Above Element places text above a selected element.  Line spacing 
determines the distance the text is placed from the element.  Other active 
style settings (size, font, justification, CO, WT, etc.) also apply. 

 Below Element works like above element, but places text below a 
selected element. 
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 View Independent and Fitted View Independent operate like By Origin 
and Fitted modes, however, the text can be read from all views in a 3D 
file and not just the placement view. 

 

 

 

 

Like other 2D elements, text is planar to the view in which it is placed 
unless you use the View Independent placement modes. 

 On Element uses the active text and element settings and clips out the 
portion of the element behind the text. 

 

 Along Element uses the active text font and size and places text along a 
selected element.  You data point to identify which side during 
placement. 

 

Text in Top View 

Text in Front View 



 Text 
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 Word Wrap places text within an area you define (corner to opposite 
corner) and then wraps the text within this limit.  You can select the text 
object with the Element Select tool and resize the text box, if desired. 

 

 

Other word processing functionality includes checking spelling prior to placing 
text and using Cut, Copy and Paste between Redline and other Windows 
applications. 

Text is placed using active text and design file parameters including: 

 Active element symbology (color, weight) 
 Active level 
 Active angle  
 Text style 

Placing Text from the CDOT menu automatically sets levels, text style, and 
symbology to the appropriate values. 
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Text justification 

 

 

When you place text, you have the option of choosing any one of the 
justification settings typically found in any word processing software. Left Top 
justification is the customary standard. 

Note:   Do not use any of the justifications containing the term Margin as 
this may generate undesirable results due to the combination of 
text settings such as maximum line length and the inclusion of 
spaces. 

 

Expand/collapse the 
Place Text dialog 

Text Justification 
settings 



 Text 
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Importing Text 
Importing text from an ASCII text file is another method of placing text.  Use 
the File > Import > Text command to import the text file.  This allows you to use 
your Word Processor to prepare your text, which is especially handy for lots of 
notes or lengthy text.  Save the file as ASCII text, and then import it into 
Redline. 

The imported text uses the active text style and can be edited using the Edit Text 
command. 

Notes: You can also Copy and Paste text from other applications if you 
don’t want to import the entire file.  When copying from 
Microsoft applications such as Word, there are known issues 
copying to the Word Processor dialog.  An example of some of 
the errors are formatting issues, stacking fractions, and crashing 
Redline. 
 
If you paste directly into the Word Processor – Text Editor 
window, the text takes on the active text style parameters, which 
can be edited before placing the text.  
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Place Note 
Activated from the CDOT menu – The Place Note tool is located in the 
CDOT Menu.  Place Note is similar to the Place Text tool in that text is placed 
in the drawing based on any text that is entered into the Text Editor — Word 
Processor window.  The main difference between the two commands is that the 
Place Note command places text that is attached to a leader line with an arrow 
at the end of that leader.  The Place Note icon in the CDOT Menu is indicated 
by a leader line. 

 

 



 Text 
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 Text Styles – Contain predefined settings for how the text is to appear 
(text height, width, font, justification, etc.).  Using text styles for the 
Place Note command is the same as using text styles for the Place Text 
command. 

 Dimension Styles – Contain predefined settings for the leader portion of 
a note as well as various settings for placing dimensions with leaders.  
Dimensioning is not covered in this manual.  For the lab exercise in this 
chapter, you are using a dimension style to determine the size and type of 
leader (line and arrow) that is attached to the text when placing the note.  
Three dimension styles are available; CDOT 1, CDOT 2, and CDOT 3.  
Each one has different settings associated to it. 
CDOT 1 – accuracy of 0.1234, straight leader line with note 
CDOT 2 – accuracy of 0.12, straight leader line with note 
CDOT 3 – feet & inches, curved leader line with note 
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Edit Text 
Edit Text is used to edit text placed in the Redline file.  The selected text is 
shown in the Text Editor window where you can quickly edit the text string or 
change text parameters or style. 

 

Spell Checker 
You can use the Spelling command on text in the Text Editor box before placing 
it in the design file.  You can also check spelling on text already placed using 
the Spell Checker command on the Text toolbar. 

 

 

 



 Text 
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Lab 4  – Text 

Objectives 
After completing this exercise you will know how to: 

 Place text using the CDOT Menu. 
 Place notes. 
 Edit text. 
 Fill in sheet border text. 

Working with Text 

Open the Design File 
1. Start Redline and open 12345DES_SAQ01.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

Place Text 
2. Window into the upper left corner of the sheet as shown. 

 

3. Activate the CDOT Menu from the Main Tool frame if it isn’t 
already activated. 

4. From the CDOT Menu, select the Show Text filter. 
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5. Select the .07 Const-100 Text item. 

Note: When any of the four available text items are selected, by 
default, the Place Text command becomes the active command. 

 

6. Set the Tool Settings Method to By Origin.  

7. Verify that the Text Style is set to .07 Const-100 (it should already 
be set because you selected that particular item from the CDOT 
Menu). 

8. Set the Active Angle to 0. 

9. Make sure the Annotation Scale lock is on.  By default it will be 
on. 
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10. In the Text Editor-Word Processor, key in the following text: 

CONTRACT ITEM 

 

11. <D> in the open column header to place the text. 

 

 

Place Text 
Here 
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Place Additional Text 
12. Select the Fit View command. 

13. Window into the area as shown. 

 

14. In the Text Editor-Word Processor, key in the following text: 

3 
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15. <D> to place the text in the two places as shown (you may have to 
pan your view). 

16. Use the Place SmartLine command to create a horizontal line to 
cross out the pieces of text as shown (refer to Lab 1 on placing a 
line if needed). 

 
 
 
 
 

 

Place and cross out 
text as shown in the 
column below 
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Place Note 
17. Select the Fit View command. 

18. Window in the area shown below. 

 

19. From the CDOT Menu, verify that the Show Text filter is selected.   

20. Select the .07 Const-100 Place Note item.  By selecting the 
desired text item from the CDOT menu, the correct text style and 
level are activated.  
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21. In the Tool Settings set the Dimension Style to CDOT 3. 

Note: Refer to the beginning of this chapter for more information on 
dimension styles.  

 

22. <D> the Expand arrow and set the options as shown. 

 

23. In the Text Editor, key in: 

QUANTITIES CHANGED  
TO REFLECT 
PROJECT PHASING 
NEEDS 
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<D> the Spell Check    icon in the Text Editor dialog.  If there are 
no spelling errors, the Information dialog box will appear. 

 

24. <D> near the “2” as shown to define the start point of the leader 
line. 

25. Move your pointer to position the text as shown, then <D> to place 
the end point of the leader. 

26. Place linework and add text as depicted. 
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Edit Text 
27. Pan to the upper left corner of the sheet. 

28. From the Text toolbar, select Edit Text. 

 

29. <D> on the text shown below (the text you placed earlier). 

30. <D> anywhere to accept the specific text for editing. 

 

 

31. In the Text Editor window, correct the text by changing it to the 
following: 

CONTRACT ITEM NAME 

 

32. <D> anywhere in the view to accept the editing of the text. 

 

Identify Text
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Fill In Border Text 
33. Window into the area as shown at the bottom of the sheet. 

 

34. From the CDOT Menu, select the Show Text filter. 

35. Select the .07 Const-100 Text item. 

36. In the Tool Settings, verify the options are set as shown. 
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37. In the Text Editor-Word Processor, key in the text:  

03-17-2006 

 

38. <D> to place the text as shown. 

 

39. Select the Fit View command. 

40. Save Settings (File > Save Settings). 
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5. Using Cells 
Permanent Groups 

If you have standard groups of elements such as symbols, details, notes, and 
borders that you use on multiple projects, you can make a permanent group of 
these graphics by creating a cell.  The workflow consists of: 

 Drawing the graphics 
 Creating a cell out of these graphics and 
 Storing the cell in a library 

When you’re ready to place the cell in your design file, attach the cell library to 
the file.  You can place the cell out of the library multiple times, like a rubber 
stamp.  The cell library can be attached to any Redline design file.  By default, 
the Construction cells will automatically be attached to the active design file. 

Each cell in the library can be either 2D or 3D and have its own working units.  
Therefore, you can have both imperial and metric cells in the same library, if 
desired. 

Cell Libraries 
Cells are the equivalent to blocks in AutoCAD.  Cell libraries are just ordinary 
Redline design files that have a .cel extension.  The cell library file contains 
multiple models and each cell is stored in a separate model. The advantage of 
cell libraries is that a single file can contain all of your cells. 

Cells can be organized into different libraries (disciplines, details, symbols, 
borders, etc.) or all cells can be placed in one library.   

Models can also be imported from other DGN files.  This is a good way to copy 
a lot of graphics from one DGN to another, or to build a cell library. 
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CDOT Cell Libraries 
Many of the CDOT standard cells have been created and are stored in discipline-
specific cell libraries (e.g. Design, Bridge, ROW).  The appropriate cell library 
or libraries are attached to the discipline seed file. 

The standard CDOT cell libraries are as follows: 

 Construction.cel 

Revision for Construction Cell Command 
The CDOT menu takes all of the work out of placing a Revision For 
Construction cell.  To place a Revision for Construction cell, open the CDOT 
Menu, change the filter to Show Cells, and choose the Revision for 
Construction item under the As-Constructed Category. 

 

This will open a Place Active Cell dialog.  Make sure that the Active Angle, 
Scale, and any placement options are selected to the desired preference and then 
simply place the cell <D> into the drawing. 
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Edit Text of an existing Revision Cell 
Once a Revision for Construction cell is placed, its text can be edited using the 
Edit Text command from the Main Tool Frame as described in Chapter 3.  
Simply <D> on the text inside the cell and the Text Editor will display allowing 
for changes. 

        

Revision Cloud Command  
A revision cloud is used to emphasize portions of a project that need attention.  
There are two methods for placing a revision cloud: using an ellipse or using 
points.  Both methods are accessed in the CDOT menu by selecting the As-
Constructed category, Show All filter, and then selecting the Revision Cloud 
item.  The Place Cloud dialog will then appear. 

 

Note: The Show All filter displays all Items found in the other filters.  
The Revision Cloud, however, can only be found in the Show 
All Filter. 
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Ellipse Method:   

 <D> where the center of the Revision Cloud will be located. 
 <D> anywhere to extend a line forming the ellipse’s major or minor axis. 
 Determine the remaining axis by moving perpendicular to the axis just 

formed, <D> to complete the cloud. 

 

Points Method: 

 Determine vertices for the cloud by <D> in the desired areas. 
 <R> to accept and auto-complete the Revision Cloud. 

 

Mark-up Cloud Command (Project Management Group) 
A Mark-Up Cloud is used by Project Managers to emphasize portions of a 
project that need attention.  There are two methods to placing a Mark-up Cloud: 
using an ellipse or using points.  Both methods are accessed in the CDOT menu 
by selecting the Mark-Ups category, Show All filter, and the Mark-up Cloud 
item,  

 

Note: The Show All filter displays all Items found in the other filters.  
The Mark-up Cloud, however, can only be found in the Show 
All Filter. 
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Ellipse Method:   

 <D> where the center of the Mark-up Cloud will be located. 
 <D> anywhere to extend a line forming the ellipse’s major or minor axis. 
 Determine the remaining axis by moving perpendicular to the axis just 

formed, <D> to complete the cloud. 

 

Points Method: 

 Determine vertices for the cloud by <D> in the desired areas. 
 <R> to accept and auto-complete the Mark-up Cloud. 
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Lab 5a – Cells (Construction Group) 

Objectives 
After completing this exercise you will know how to: 

 Activate a cell for placement from the CDOT Menu. 
 Place a cell into the drawing. 
 Edit the text contained in a cell. 
 Use the Revision Cloud command. 

Placing Cells into the Drawing 

Open the Design File 
1. Start Redline and open 12345DES_PnP18.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

Create a Culvert 
2. Window into the area as shown. 

 

3. Activate the CDOT Menu from the Main Tool frame, if it isn’t 
already activated. 

4. Select the As-Constructed category. 

5. Select the Show Lines filter. 

6. Then select the Linework item. 

7. The Place SmartLine command is automatically selected.   
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8. Set the Settings options as shown. 

 

9. <D> to start the line approximately as shown. 

10. <D> to end the line approximately as shown. 

 

Start the line here 
 

End the line here 
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Place Text 
11. From the CDOT Menu, select the Show Text filter. 

12. Select the .07 Const-100 Text item. 

The Place Text command is selected. 

13. Set the Settings options as shown. 

 

14. In the Text Editor-Word Processor, key in the text below. 

STA 350+03.05 

 

15. <D> to place the text approximately as shown. 

 

Place the text here 
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Place the Revision For Construction Cell 
16. From the CDOT Menu, select the Show Cells filter. 

17. Select the Revision For Construction item. 

Note: When the Revision For Construction item is selected, by 
default, the Place Cell command becomes the active command. 

 

 

18. Select the Settings button. 

 

19. Set the Active Scale to 100. 

 

20. Select Apply. 
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21. Verify the Settings options are set as shown. 

 

22. <D> to place the cell approximately as shown. 

 

Edit the Text of the Cell 
23. Select the Edit Text command from the Text toolbar. 

 

24. Identify the “CO-XX” text of the cell that was just placed and <D> 
anywhere to accept it. 

 

25. In the Text Editor-Word Processor, key in the text below. 

CO-13 

Place the cell here
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26. <D> anywhere in the view window to accept the editing of the text. 

The text contained in the cell is changed. 

 

Place a cloud element using the Revision Cloud command 
27. From the CDOT Menu, select the All filter. 

28. Select the Revision Cloud item. 

Note: When the Revision Cloud item is selected, by default, the Place 
Cloud command becomes the active command (there isn’t a 
Place Cloud icon located on the Main Tool frame). 

 

29. Set the Settings option to Points. 
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30. <D> several times (5-8 clicks) to create a shape approximately as 
shown around the culvert, text, and cell that was placed earlier (the 
shape doesn’t need to be closed). 

31. When a shape has been created to appear approximately as shown, 
<R> to complete the command. 

 

A cloud element is created. 

 

Create a shape 
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Lab 5b – Cells (Project Management Group) 

Objectives 
After completing this exercise you will know how to: 

 Use the Mark-up Cloud command. 

Placing Cells into the Drawing 

Open the Design File 
1. Start Redline and open 12345DES_PnP18.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

Indicate that a Culvert is to be Added to the Drawing 
2. Window into the area as shown. 

 

3. Activate the CDOT Menu from the Main Tool frame, if it isn’t 
already activated. 

4. Select the Mark-Ups category. 

5. Select the Show Lines filter. 

6. Then select the Color Green (Add) item. 

7. The Place SmartLine command is automatically selected.   

 

8. Set the Settings options as shown. 
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9. <D> to start the line approximately as shown. 

10. <D> to end the line approximately as shown. 

  

Place a cloud element using the Mark-up Cloud command 
11. From the CDOT Menu, select the All filter. 

12. Then select the Mark-up Cloud item. 

Note: When the Mark-up Cloud item is selected, by default, the 
Place Cloud command becomes the active command (there 
isn’t a Place Cloud icon located on the Main Tool frame). 

Start the line here 
 

End the line here
 



 Cells 

 

Bentley Redline Essentials  Page 139 

 

13. Set the Settings option to Points. 

 

14. <D> several times (5-8 clicks) to create a shape approximately as 
shown around the line that was just placed (the shape doesn’t need 
to be closed). 

15. When a shape has been created to appear approximately as shown, 
<R> to complete the command. 

 

Create a shape  
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A cloud element is created. 
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6. References and Level Display 

Referencing Basics 
References are models (individual files) that are attached to the active model.  
When the graphics of a reference file are ‘attached’ they are not actually ‘in’ the 
file.  The graphics are background data and cannot be manipulated.  However, 
these graphics can be copied into the active model, which would then allow for 
normal modifications and manipulations. 

When opening a MicroStation model in Redline, a copy of the MicroStation file 
is created.  The file that is created is given the same file name as in 
MicroStation, however, a different extension is used.  The extension that is 
applied is the user name (e.g. .cotrain01).  Also, when a MicroStation file is 
opened in Redline, the MicroStation file is automatically referenced into the 
Redline file.  The purpose of this is to allow the user to be able to review the 
graphics of the MicroStation file without directly changing it.  Hence, every 
Redline file opened will have a reference file automatically attached.  This 
reference file is termed a Reviewed File.   

Note:  Copying and/or modifying elements should only be done in the 
Redline file. Changes to elements contained in the Reviewed file, 
will change the original content and intent of the drawing being 
reviewed or marked-up 

Reference Dialog Box 
Access the References dialog box by selecting File > References or by simply 
clicking on the icon from the Primary Tools toolbar. 

 

The References dialog box should resemble the following: 
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Nesting 
When references are attached, the user has the option of attaching a single 
specific file, or the specified file plus any references previously made to that 
file. In other words, references of references otherwise call nested refrences. 

Notice in the example below, the title bar contains 4 unique and 4 displayed 
references.  Yet, the dialog box indicates only one attached reference file, the 
12345DES_PnP02.dgn file.  This is due to reference nesting and, in this case, the 
file having three nested references attached to the Reviewed File.   A nested 
reference is a model that is attached (referenced) to a specific file that happens 
to be referenced itself to another file.  

 

Note:  If desired, nesting can be turned off by simply changing the 
nesting type option at the bottom of the dialog box from Live 
Nesting to No Nesting. 

 

Reference Attachment Settings 
There are three main attachment settings that can be turned on and off from the 
References dialog box.  These settings can be toggled from two different 
locations inside of the References dialog: 

Display - turns the entire reference on or off.  By default, it is toggled on. 

Snap - allows tentative snapping to reference graphics.  By default, it is 
toggled on. 

Locate - allows for selecting, measuring, copying, and analyzing of the 
reference.  By default, it is toggled off. 

Active File
Main Reference
Nested Reference 
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Level Display 

What is Level Display? 
Level Display is used to assist in separating graphics in the design file.  
Graphics placed on different levels are easily controlled by toggling different 
levels on or off.  Levels are synonymous with layers in AutoCAD. 

All levels, including markup and reference levels, are controlled by the Level 
Display dialog box.  To access the Level Display dialog box, select Settings > 
Level >Display or simply click on the icon from the Primary Tools toolbar. 

 

When a reference is attached, all levels from the original file are attached as 
well, allowing for specific control.  This is a beneficial feature for setting up 
plots, viewing, or printing a file. 

The Level Display dialog box should resemble the following: 
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Organizing the List of Levels 
To assist in sorting the list of levels that is displayed in the dialog, the list can be 
sorted based on the different columns (e.g. Name and Used columns).  Simply 
click on the column heading and the list will automatically sort based on the 
specific column that is identified. 

Note:  The individual columns can be resized (narrowed or widened) as 
needed.  Also, the columns can be reorganized.  <D>, hold, and 
drag a specific column to a different horizontal location (the 
Level Display dialog may have be resized to do so). 

 

Turning Levels On/Off 
Individual levels can be turned on or off simply by <D> on the level from the 
list.  The background of a level that is off turns gray. 

 

Level is ON

Level is OFF
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Used vs. Unused Levels 
Individual levels turn bold if there are one or more elements in the drawing that 
are located on the particular level.  The other way to identify whether a specific 
level has element(s) on it, is to refer to the Used column.  A filled circle in that 
column, indicates that the level has one or more elements on it. 

 

  <R> on any level produces a flyout menu that allows for additional options: 

 All On - turns all levels on within the selected file. 
 All Off - turns all levels off within the selected file. 
 Invert Selection - all levels are inverted.  Levels that were selected to be 

displayed are now off while levels that were off are now displayed. 
 Off By Element - allows users to turn off a level by identifying an 

element on that particular level.   

Note:  Using the Off By Element method helps to minimize that chance 
of accidentally turning off a level that is desired to remain on.  
The other methods located in the flyout menu can substantially 
impact the look of the drawing.  If levels are accidentally turned 
off, the View Previous command (from the View Control 
toolbar) can be useful for turning those levels back on. 

 All Except Element - allows user to turn off all levels, expect for the 
level that contains the element that is identified.  

 

Level does not 
have elements on it

Level has element(s) on it
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Change Element Attributes Command 
Often times it is desired to change the level that an existing element is on.  One 
way to do this would be to delete the graphics and then recreate it using the 
correct level.  In most situations, however, a more efficient way of 
accomplishing this would be to simply change the attributes (level) of the 
existing element.  Using the Change Element Attribute command provides a 
quick way of changing the level an element is on. 

 Select the Change Element Attribute command from the Main Tool 
frame. 

 

 In the Tool Settings dialog, activate the Level check box. 
 <D> on the drop down arrow and identify the level that is desired to 

place the existing element(s) on. 

 

 Then simply <D> on the element that is desired to change. 
 <D> to accept the command.   
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Lab 6 – References and Level Display 

Objectives 
After completing this exercise you will know how to: 

 Use various settings from the Reference dialog box. 
 Control the display of references using Level Display. 
 Copy graphics into the active file from an attached reference. 
 Change the attributes of elements in the active file. 

Working with References 

Open an existing Redline Design File 
1.  Open the following directory: 

 C:\Projects\12345\Redline 

2. Change the List Files of Type option to: 
 *.cotrain01 (All Files [*.*] could also be used) 
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3. Open the 12345DES_PnP01.cotrain01 file (this file was used for 
Chapter 2).  This existing .cotrain01 file is opened to view any 
previous markups or edits that were made to the file. 

Note: Recall from Chapter 1 that: 
The .cotrain01 extension is automatically applied at the end of a 
file name when a Redline file is opened and a copy is made.  
(Example:  When 12345DES_TitleSht.dgn is opened from the 
12345\Design\Drawing folder, a copy of that specific file is 
automatically made and, by default, it is saved in the 
12345\Redline folder.  The new file that is made is given the 
user specific extension, 12345DES_TitleSht.cotrain01).   

4. Fit View to display all elements. 
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Using the Reference Dialog Box 
5. Select File > References or select the icon from the Primary Tools 

toolbar.  The References dialog box will open. 

 

Notice that one reference is displayed, the 12345DES_PnP01.dgn file. 

 

Turn the display of the reference on and off. 

6. Toggle the Display check mark off.  This will turn off all graphics 
included in the specific reference. 

 

7. Toggle the Display check mark back on. 

8. Close the References dialog box. 

Display Checkbox 
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Using the Level Display Dialog Box 
9. Select Settings > Level > Display or select the Level Display icon 

from the Primary Tools toolbar.  

 

Level Display opens containing a list of all the available levels. 

10. Resize the dialog and reorganize the columns as needed (Name, 
Used, etc.) so that the Level Display dialog appears similar to as 
shown.  

 

Add some graphics to the design file. 

11. Window into the area as shown. 
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12. From the CDOT menu, select the As-Constructed category. 

13. Select the Show Lines filter. 

14. Select the Linework item. 

15. Select the Place Circle command. 

 

16. Activate the Diameter checkbox, and enter a value of 10 which 
will draw a 10-foot diameter circle. 

17. Make sure the other options are set as shown. 

 

18. Place the circle approximately as shown. 

 

19. <R> to get out of the command. 

20. Select the Show Text filter. 

Place the circle here
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21. Select the .07 Const-100 Text item. 

22. Set the Settings as shown. 

 

23. Enter the following text: 

CULVERT 
ADDED 

 

24. <D> to place the text approximately as shown. 

 

25. <R> to get out of the command. 

Turn specific levels of the active file on and off using Level Display. 

Note:  Extreme caution should be exercised when manipulating the 
levels of a reference and levels of the active file.  Such 
manipulations will have a direct effect on the appearance of the 
graphics resulting in making comments and/or mark-ups to a 
drawing having a different composition from the original.  

Place the text here 
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Use the column headings to sort the list of levels. 

26. <D> on the Used column so that the level list appears as shown. 

 

27. <D> on the CONST_As-Construct-Linework level. 

The background of the selected level turns gray, indicating that the level is off.   

 

Notice that the circle that was placed earlier on that level is now not visible.   
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Note:  It is often beneficial to be able to turn off the display of graphics 
that are on a specific level for printing, viewing, selecting, and 
other purposes.  

28. <D> on the CONST_As-Construct-Linework level again to turn 
the level back on. 

 

Turn specific levels of the reference file on and off using Level Display. 

29. Select the Show Target Tree option.  This will provide the option 
for displaying the list of levels of the reference file as well as the 
active model. 
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30. <D> on the Reviewed File, 12345DES_PnP01.dgn file located in 
the Target Tree list. 

 

Notice that the list of levels changed because you are now looking at levels that 
are specific only for the reference file and not the active file. 

 

Levels for the
reference file
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31. <D> on the ALG_PROPOSED_Ver-Alignment-Text level. 

The background of the selected level turns gray, indicating that the level is off.   

 

Notice that a variety of elements are located on that level, as they are currently 
not displayed.   

 

32. Select File > Save Settings.  This preserves the manipulation of 
levels.  So the next time this file will be opened, Redline will recall 
which levels were turned on and off at the time the Save Settings 
command was initiated. 

33. Close the Level Display dialog. 
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Copy Graphics from the Reference File 
34. Select the Fit View command. 

35. Window into the area as shown (upper-left corner of the sheet). 

 

36. Open the References dialog. 

37. Activate the Locate option as shown.  With this option turned on, 
elements contained in the reference file can be selected. 
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38. Using the Element Selection tool, select the tree as shown. 

 

39. Select the Copy command. 

 

40. <D> near the selected tree. 

41. <D> to place the copied graphics approximately as shown. 

 

Note:  The tree element that was just placed in the drawing is located in 
the active design file, 12345DES_PnP01.cotrain01.  Whereas, 
the original tree element is located in the reference file, 
12345DES_PnP01.dgn.  When copying elements from an 
attached reference file, make sure that this operation is to be 
performed versus making the copy in the reference file itself.   

42. Practice turning the respective levels on and off for the two trees 
using Level Display. 

 

Selection Boundary

Copy here 
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Change the Attributes of the “Copied” Graphics 
It is desired to place the tree that was just copied on a different level.  To do so, 
the Change Element Attributes command will be used. 

43. Select the Change Element Attributes command. 

 

44. Activate the Level checkbox. 

45. From the pull-down option, select TOPO_LANDSCPE_Misc 

 

46. <D> anywhere on the tree as shown. 

 

47. <D> to accept the command. 

The tree that was identified is now on the desired level, TOPO_LANDSCPE_Misc.  
This was done without having to recreate the graphics, which is a big advantage 
of using the Change Element Attributes command. 
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7. Snapping and Measuring 

Snapping 

What is Snapping? 
Snapping is a procedure of identifying an exact point or location on an existing 
element for drawing or modification purposes.  Snapping is especially beneficial 
when using various measuring commands.  To aide in determining an exact 
point or location, snap modes can be utilized. 

Snap Modes 
The active snap mode determines how to snap onto an element.  The following 
snap modes can be used from the Snap Mode toolbar: 

 

 Nearest — snaps to a point on the element nearest your pointer. 
 Keypoint — snaps to the nearest element keypoint.  Typical keypoints 

are endpoints of lines and arcs, corners of blocks, vertices of shapes, 
center of circles. Keypoint is one of the most useful snap modes. 

Note: When using Keypoint snap mode, you can set the keypoint 
Divisor to determine intermediate keypoints snaps.  For example, 
a Divisor value of 2 allows you to snap to the midpoint of a line.  
Set the divisor on the Full Locks settings box.  You can also set 
the Divisor using the key-in KY=<value >. 

 Midpoint — snaps to the midpoint of the element segment (line, arc, 
etc.). 

 Center — snaps to the center of elements (circles, arcs, etc.). 
 Origin — snaps to the first vertex of a line, linestring or shape.  Snaps to 

the origin of a cell or text, and the first data point in a dimension 
element. 

 Bisector — snaps to the midpoint of a linestring, multi-line, or complex 
chain.  Snaps to the midpoint of a line or arc. 

 Intersection — snaps to the intersection of two elements. 
 Tangent — when placing a new line, snaps to an existing element (like a 

circle) where the new line is dynamically tangent to the element. 
 Tangent Point — behaves like the Tangent snap mode except you lock 

the tangent point. 
 Perp — when placing a new line, snaps to an existing element (like a 

circle) where the new line is dynamically perpendicular to the element. 
 Perp Point — behaves like the Perp snap mode, except you lock the 

perpendicular point. 
 Parallel — when you snap to an existing line, the new line you place is 

parallel to the line to which you snapped. 
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 Through Point — defines the point on an existing element through 
which the new element that is placed must pass. 

 Point On — defines the point on an existing element where the next data 
point of a new element must lie. 

 Multi-snap — used to set up groups of snaps.  With a Multi-snap set as 
the active snap mode, a predefined set of snaps (e.g. Intersection, Center, 
Midpoint, etc.) can be utilized all at once. 

Using a Snap Mode 
The procedure for using a snap mode is as follows: 

 Activate a drawing or manipulation command. 
 Select the desired snap mode from the Snap Mode toolbar. 
 <T> (tentative/middle mouse button) on the element that is desired to 

snap to.  A large crosshair symbol will appear on the element at the 
location in which the snap mode identified (end point, mid point, center, 
etc.). 

 

 If the large crosshair symbol appears at the correct location, <D> 
anywhere to accept that snap location. 

Note:  The Intersection snap mode requires a second <T> (one on each 
of the two elements that make up the intersection point).  

Active vs. Default Snap Mode 
When identifying a snap mode to utilize, a specific snap mode can be set as the 
active or default snap mode. 

 Active – Only one snap mode can be set as the active snap mode.  The 
active snap mode is the snap that is used.  This is a one time operation, 
meaning that once the active snap mode is used the active snap mode 
will then automatically become the snap mode that is currently set as the 
default snap mode.  To set a snap mode as the active snap, <D> on any 
of the snap modes from the snap mode button bar.   

 Default – There can be only one default snap mode at a time.  Unlike the 
active, the default snap mode is unlimited in the number of times it can 
be utilized.  The default can also be the active snap mode (note above 
info on the active snap).  To set a snap mode as the default snap, 
<D><D> (double-click) on any of the snap modes from the snap mode 
button bar.    
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 Default 
snap mode 

                         

Active 
snap mode 
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Measure Toolbar 

 

The Measure toolbar is used to measure distances, angles, radii and areas.  Use 
Settings > Design File > Coordinate Readout to define how measurement 
values will display (units, precision, etc.) 

In a 3D file, if you want a planar measurement, turn on Depth lock before using 
the appropriate measure command.  If you want a true slope measurement, turn 
off Depth lock. 

When a measuring command is used and it is desired to review the results, refer 
to the Tool Settings dialog.  



Colorado Department of Transportation 

 
 

Page 166  Bentley Redline Essentials 

Some of the more commonly used measuring commands include: 

Measure Distance 
Measures distance using one of the following methods: 

  

 Between Points 
 Along Element 
 Perpendicular 

Note:  This command locks on the element’s depth you are measuring 
from when starting the measurement.  If you want a horizontal 
measurement, you must first set the Active Depth to the depth 
of the element and make certain Depth lock is on. 

 Minimum Between 

Measure Radius 
Measures the radius of a circle or an arc.  It also measures the circular segment 
of a complex chain or shape, or the primary and secondary axes of an ellipse. 

 

Measure Angle 
Measures the angle between two lines or line strings, or the angle between two 
segments of a shape. 
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Measure Length 
Measures the length of an element or the perimeter of a shape. 

 

Measure Area 
Measures area using the same method options as the Pattern commands. This 
includes the area of a shape (Element method) or an area you dynamically 
define using the Points method.  In addition, you can Flood an area or measure 
the area of the Intersection, Union or Difference between elements. 
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Lab 7 – Measuring 

Objectives 
After completing this exercise you will know how to: 

 Use various snap modes when snapping to elements. 
 Measure distances. 
 Measure radii. 
 Measure the angle between lines. 
 Measure areas. 

Practice Snapping and using some Measuring Tools 

Open the Design File 
1. Start Redline and open 12345SURV_Topo100.dgn from the 

C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 
folder. 

Manipulate the Appearance of the Graphics 
2. Open the References dialog. 

3. If the Nesting is turned on, turn it off by selecting the No Nesting 
option as shown.  Since the graphics that will be used for 
measuring are located in the main reference, it is not necessary to 
display nested references as well. 

 

4. Turn on the Locate option. 
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5. Close the References dialog. 

6. Open the Level Display dialog. 

7. In the reference file 
Reviewed File, 12345SURV_Topo100.dgn,  
turn off the following levels: 
TOPO_TERRAIN_Break-Lines  
TOPO_TERRAIN_Terrain-Single-Shots 

 

8. Close the Level Display dialog. 

9. File > Save Settings 

The graphics should appear as shown. 
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Turn on the Depth Lock 
10. From the status bar (bottom of the Redline interface), select the 

Locks field.  A fly out will appear. 

11. Make sure the Depth Lock is on as shown.  If it is turned off, <D> 
on the Depth option and the checkmark will appear. 

 

Note:  Turning on the Depth Lock will ensure planar measurements and 
not 3D measurements for specific measuring commands. 

Measure Distance 
Measure Distance - Use the Between Points method. 

12. Window into the area as shown. 

 

 

 
Window in here 
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The view window should show the following graphics. 

 

13. Select the Measure Distance command from the Measure toolbar.  

 

14. Set the Distance option to Between Points. 

 

15. Set the Keypoint snap mode as the default snap mode. 

 

16. <T> approximately on the left end of the dashed line (culvert) as 
shown (you may need to zoom in further). 
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The cross hair symbol appears at the end of the line.  Also, the line that is 
identified highlights. 

 

17. If the correct element is highlighted, <D> to accept the location. 

The “tentative” cross 
hair symbol appears 

The identified 
element highlights
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18. <T> approximately on the right end of the dashed line (culvert) as 
shown (you may need to zoom in even further). 

A temporary measuring reference line is drawn from tentative point to tentative 
point. 
 

 
 

 

 

19. If the tentative symbol appears at the correct location, <D> to accept. 

20. <R> to reset the command. 

21. Check the Tool Settings for the measurement. 

Verify the measurement, 152.282’. 

 

Note: Measurement readouts can be copied to the clipboard from the 
Tool Settings dialog.  This comes in handy if it is desired to 
place the readout information in another application (e.g. Word 
or Excel) or in Redline using the Place Text command.  To copy 
the information, <D> on the text, hold, and drag to select the 
text.  Press Ctrl+C to copy the text to the clipboard or <R> to get 

The “tentative” cross 
hair symbol appears 
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an editing fly out menu.  Then simply paste that information 
where and when desired. 

 

Measure Distance - Use the Along Element method. 

22. Set the Distance option for the Measure Distance command to 
Along Element. 

 

 

23. Use the same procedure that was just used (<T> at each end point) to 
measure the pavement marking line shown below. 

 

24. Record your results: _________________________ feet 

Note: See the last page of this lab for all measurement answers. 

 

Measure this line using the 
Along Element method 
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Measure Radius 
25. Select the Measure Radius command from the Measure toolbar. 

 

 

26. <D> on the arc as shown. 

27. <D> to accept the command. 

 

 

28. Record your results: ___________Radius, ___________Diameter 

 

<D> here
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Measure the Angle between Lines 
29. Select the Measure Angle command from the Measure toolbar. 

 

 

30. <D> on the fence line as shown. 

The entire element will highlight. 

31. <D> on the other side of the fence as shown. 

32. <D> to accept the command. 

 

33. Record your results: _________________________ 

 

<D> here 
for the first 
element 

<D> here for 
the second 
element 



 Snapping and Measuring 

Bentley Redline Essentials  Page 177 

Measure Length 
34. Select the Measure Length command from the Measure toolbar. 

 

 

35. <D> on the gas line as shown. 

36. <D> to accept the command. 

 

 

 
 

37. Record your results: _________________________ feet 

 

<D> here
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Measure Area 
38. Select the Measure Area command from the Measure toolbar. 

39. Set the Method to Element. 

 

 

40. <D> anywhere on the perimeter of the building as shown. 

41. <D> to accept the command. 

 

 

 

 

42. Record your results: 
Area_______________ square feet, Perimeter: _____________ feet 

43. Practice using various measuring tools and methods as well as snap 
modes on your own if time allows. 
 

<D> on the perimeter 
of the building 
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Answers to Measurements 
Measure Distance (Along Element method):  71.168' 

Measure Radius:  60.00’ Radius, 120.00’ Diameter 

Measure Angle:  108°14'48.14" 

Measure Length:  188.664’ 

Measure Area:  2144.7387’ Area, 202.0262’ Perimeter 
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8. Fences and Printing 

Fence Toolbar 

 

The Fence toolbar provides another set of tools to temporarily group elements.  
Once placed in the fence, the elements can be printed, deleted, manipulated or 
the attributes changed.  When the fence is removed, the elements are no longer 
grouped. 

Place Fence 
Temporarily groups elements by drawing a fence boundary around the elements.  
There are several types of fences you can place including blocks (drawn corner 
to opposite corner), shapes, and circles, also by element, view or design file. 

     

The fence mode determines which elements will be affected by the fence.  These 
include: 

 Inside — to select elements entirely inside the fence. 
 Overlap — to select elements inside or overlapping the fence. 
 Clip — to select elements inside the fence and cut or break all elements 

that intersect the fence. 
 Void — to select all elements outside the fence. 
 Void-Overlap — to select all elements outside or overlapping the fence. 
 Void-Clip — to select elements outside the fence and cut or break all 

elements that intersect the fence. 

Once the elements are grouped in the fence, they can be deleted or manipulated.  
You can use Redline view controls (Zoom In, Zoom Out, Pan, etc.) and the 
fence remains persistent. 

To remove the fence, select the Place Fence command again. 

Note:  Check the fence indicator on the Status Bar to quickly determine 
if there is a fence placed in the design file. 
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The Void and Clip modes are two features not available with selection sets.  
However, there may be times when attribute filtering (not available with fences) 
is easier to use — especially when grouping graphics in high-density areas. 

To group elements with a fence: 

 Select the Place Fence command. 

Set the fence Type and Mode. 

 Enter data points to define the fence (block, shape, etc.) 

If placing a fence shape, select Close Fence. 

Modify Fence 

     

The Vertex mode allows you to modify a fence vertex to include or exclude 
elements in the fence without having to re-draw the fence.  The Position mode 
lets you move the entire fence to include or exclude elements in the fence. 

Delete Fence Contents 
Deletes the contents of the fence based on the fence mode.  Note that the Delete 
Element command on the Main tool frame does not work for fenced elements. 

     

To delete the contents of a fence: 

 Select the Delete Fence Contents command. 
 Set/check the Fence Mode in the tool settings box. 
 <D> to accept the deletion. 

CAUTION: If the fence mode is set to a Void mode, all elements OUTSIDE the 
fence will be deleted. 

Note:  It is good practice when working with fence modes to always set 
the Mode back to Inside so that accidental deletions are 
avoided. 

CDOT Batch Printing 
Batch Printing is used to print multiple files at one time. This tool can assist you 
in organizing Plot Sets for milestone submittals.  A file can be saved (given a 
.job extension) and called back for future printing.  It can also be used for 
plotting to Adobe Acrobat format (PDF).  See page 15 for reference information 
about accessing CDOT CADD resources and documentation 
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Lab 8 – Fences and Printing 

Objectives 
After completing this exercise you will know how to: 

 Place a fence. 
 Set the print options. 
 Print to PDF file format. 
 Utilize batch printing. 

Utilize the Fence commands and practice Printing 

Open the Design File 
1. Open 12345DES_SAQ01.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

Printing a Sheet 
Place a Fence to define the printing boundary. 

2. Select the Place Fence command. 

 

3. Set the Fence Type to Block and Fence Mode to Inside. 

 

4. <T> approximately as shown (upper-left corner of the border 
sheet).   

 

<T> here



Colorado Department of Transportation 

 
 

Page 184  Bentley Redline Essentials 

A large cross hair symbol appears. 

 

5. <D> anywhere to accept the location. 

The location of one corner of the fence is now identified. 

 

6. Pan or scroll to the opposite corner of the border sheet. 

7. <T> approximately as shown.   
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A large cross hair symbol appears. 

 

8. <D> anywhere to accept the location. 

The fence is now placed around the outer boundary of the border sheet. 

Set the print options. 

9. Select File > Print or choose the Print icon from the Standard 
toolbar. 

 

10. If prompted, select CDOT-DefaultPrinter.plt for the print driver.   

 

11. Select OK. 



Colorado Department of Transportation 

 
 

Page 186  Bentley Redline Essentials 

12. If the Select Printer Driver File dialog doesn’t appear, select the 
Select Printer Driver icon (magnifying glass icon) as shown 
below. 

 

13. Set the dialog as shown here. 

  

14. From the Print dialog, select the Print icon or File > Print. 
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Print to PDF File Format 
15. From the Print dialog, select File > Select Bentley Driver, or 

select the Select Printer Driver icon (magnifying glass icon). 

16. Select CDOT-PDFdriver.plt. 

 

17. Select OK. 

18. The Print dialog should appear as shown. 
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19. Select the Print icon or File > Print. 

20. Set the Directory to C:\Projects\12345\Plot_Sets\FOR. 

Note: The name should default to your file name with a .pdf extension. 

21. Select OK and the PDF file is generated. 

 

22. Go out to the output directory and double-click the new PDF file. 
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CDOT Batch Printing 
23. From the CDOT Menu, select Help > Workflows. 

 

This will launch the CDOT internal site.  From there, a detailed workflow on 
Batch Printing can be accessed, called CDOT Batch Printing. 

24. Using the CDOT Batch Printing workflow, create a PDF batch 
print of the following files you have been working with: 
 
C:\Projects\12345\Redline\12345DES_GenNote.cotrain01 
C:\Projects\12345\Redline\12345DES_PnP01.cotrain01 
C:\Projects\12345\Redline\12345DES_PnP18.cotrain01 
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Appendix A 

Using AccuSnap 
AccuSnap is a feature that streamlines your snaps.  Instead of tentative 
snapping to an element, you can AccuSnap to it.  In addition, AccuSnap can 
give you basic element information and can identify whether a tool can be used 
on a specific element. 

To snap to an element using AccuSnap: 

 Select a drawing tool. 
 Select a Snap mode. 
 Move your pointer across the element. 

AccuSnap identifies the element type and its level with Pop-up 
information.  An icon representing the current snap mode is displayed 
along with a tentative hint – a light dashed cross-hair at the closest snap 
point according to the selected snap mode. 

 

 

 

 

 

 

 Move your pointer closer to the tentative hint. 

The pointer changes to a bold X and the element highlights to indicate 
you’re locked on to the snap point. 

 

 

 <D> to select this location. 

A Tentative point is not necessary to define the temporary snap location. 

Tentative hint 

Active snap icon 
Pointer location 

Pop-up info 

AccuSnap locked location
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AccuSnap Settings 
There are several options to control how AccuSnap works.  Find these settings 
by selecting the snaps button on the Status Bar or by right-clicking AccuSnap 
on the Snaps Button Bar and choosing Properties. 

 

For example, you can choose to turn the tentative hint on or off, highlight all 
elements or just the active when a snap point is found, or no highlight, turn pop-
up information on or off, and disable or enable AccuSnap altogether.  
Experiment with these options to determine how you like to work. 

Note:  If you don’t want AccuSnap to highlight all elements you pass 
with your pointer, turn off Hilite active element in AccuSnap 
Settings. 

Snap Modes 
For more information on snap modes, refer to Chapter 7. 

Multi-Snaps 
Redline includes three Multi-Snap modes.  Multi-snaps are an ordered list of 
snaps. When you choose a multi-snap with AccuSnap on, Redline processes 
the multiple snaps according to your pointer location. 

Using Multi-Snaps 

 From the Snaps button bar or from the Status bar, select a Multi-Snap 
(Multi-snap1, Multi-snap2 or Multi-snap3). 

 

 Move your pointer over the element until AccuSnap locates the first 
multi-snap option. 
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 Continue moving your pointer until the next snap option highlights. 
 When you have locked on the correct snap point, <D> to accept. 
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Editing Multi-Snaps 

 Select Multi-snaps from the Snaps button on the Status bar. 
 Select a multi-snap (1, 2 or 3). 

 

Note: You can also right-click on the Multi-snap icon from the Button 
toolbar and select Properties. 

 Toggle on the snaps you want to include in the multi-snap. 
 Toggle off snaps you don’t want. 
 Close the Multi-snaps box. 
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Appendix B 

AccuDraw 
AccuDraw is a precision drawing tool that streamlines the placement of data 
points.  It basically combines the techniques of precision key-ins with axis lock-
type features into one command to help you place, modify or manipulate 
elements. 

AccuDraw is context sensitive.  Its behavior changes depending on which 
drawing tool you’ve selected.  AccuDraw will evaluate your current position, 
the previous data point, and the drawing tool’s needs to help you place your next 
data point.  

Starting AccuDraw 
In the CDOT workspace, AccuDraw automatically loads when you open a 
design file.  If you don’t want to use AccuDraw, you can toggle it off by 
selecting the Toggle AccuDraw button from the Primary Tools toolbar. 

 

The AccuDraw Compass 
When you start AccuDraw, one of the first things you notice is the AccuDraw 
compass. The compass shows your origin location (current drawing location) 
and defines your drawing plane.  There are two different drawing plane modes 
and, therefore, two different compasses: rectangular and polar.  

                    

 

The rectangular mode allows you to enter coordinates or delta distances, relative 
to the origin point, in an X,Y, Z coordinate system (like an XY=, DX= or DL= 
key-in).  The polar mode allows you to enter distances and angles relative to an 
origin point (like a DI= key-in).  

Rectangular mode Polar mode
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The AccuDraw Window 
The AccuDraw window is where you enter your X,Y,Z or Distance and Angle 
values. You can also lock the drawing axes. The window changes according to 
your compass mode. 

               

 

Note: To toggle the compass (rectangular and polar mode), set the 
focus into the AccuDraw window and press <Spacebar>. 

You can dock the AccuDraw window at the top or bottom of the Redline 
window or you can float the window into the view. 

 Using AccuDraw – Place SmartLine Example 
AccuDraw behaves differently with different tools, so it takes practice to 
understand all of its capabilities and nuances.  It is very intuitive, however, so 
with a little practice, it should become very user-friendly. 

Below is an example of using AccuDraw with the SmartLine command: 

 Select Place SmartLine. 
 Enter a data point to set the origin point. 

Notes: You can either just data point in the design file, use an XY= key-
in, or enter and lock the X, Y and Z coordinates for the first point 
in the AccuDraw window. 
 
The AccuDraw compass appears at the origin point. If you need 
to changes modes, press <Spacebar>. 

Rectangular mode Polar mode
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For Rectangular Mode: 
 In the AccuDraw window enter the X, Y and Z coordinates for the delta 

distance to move from your current location.  If you don’t specify a Z 
value, the data point is entered at the active depth. 

 

 

Note: When you key a value in the AccuDraw window and press 
<Enter>, it automatically locks the axis and maneuvers to the 
next field (you can also use the Tab or Arrow keys).  

 AccuDraw shows you a preview of the entry and constrains your data 
point.  Move your pointer if you want to place the data point in the 
negative X or Y direction.  Then, <D> to accept or <R> to start over. 

 

 

  The AccuDraw compass rotates so that your drawing plane is 
“in line” with the element you’ve drawn.  (The red X-axis rotates 
in line with the element.)  This makes it easy to place the next 
point relative to the element (either orthogonal or in line with the 
element).  

 

A delta distance of 100 in the X 
direction and 50 in the Y direction 
entered using AccuDraw’s 
rectangular compass. 
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 Swing your pointer to lock on to an axis and then enter your next X,Y 
value in the AccuDraw window.  

Note:  As you move your pointer, the focus (cursor location) is set to 
the appropriate location in the AccuDraw window (X or Y axis).  

 

 

 Alternatively, you can enter another X,Y delta distance from the rotated 
axis. 

 Continue entering data points until your SmartLine is complete. 
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For Polar Mode: 
 In the AccuDraw window enter the Distance and Angle values to move 

from your current location.  

Note: When you key a Distance value in the AccuDraw window, it 
automatically locks the axis. Use the Tab or Arrow keys to 
maneuver to the Angle field. If you enter an angle value, it’s 
automatically locked. Or, you can lock on to the 0°, 90°, -90°, or 
180° axes by pressing <Enter>. 

 

 

Note: If your Coordinate Readout is set to Bearing mode and you 
enter the angle value in Conventional mode (or vice-versa), the 
angle is converted automatically. 

 

 AccuDraw shows you a preview of the entry and constrains your data 
point. Move your pointer if you want to place the line in the opposite 
direction. Then, <D> to accept or <R> to start over. 
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 The AccuDraw compass rotates so that your drawing plane is “in line” 
with the element you’ve drawn.  (The red X-axis rotates in line with the 
element).  This makes it easy to place the next point relative to the 
element (e.g. orthogonal to the element, in line with the element or at a 
specified angle off of the element just placed).  

 

 Swing your pointer to lock on to an orthogonal axis and then enter your 
next Distance value in the AccuDraw window.  

 

 Alternatively, you can enter another Distance and Angle from the 
rotated axis. 

 Continue entering data points until your SmartLine is complete. 

AccuDraw Locks 
You can lock your X, Y or Distance, Angle entries by pressing the <Enter> key 
as described earlier.  Locking can also be accomplished by “dynamically” 
locking a specific field in the AccuDraw window.  Use the following keyboard 
shortcuts to lock dynamic entries: 

 <X> – to lock x-axis entries in rectangular mode. 
 <Y> – to lock y-axis entries in rectangular mode. 
 <D> – to lock distance entries in polar mode. 
 <A> – to lock angle entries in polar mode. 
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Rotating the AccuDraw Compass 
There may be times when you do not want the AccuDraw compass to rotate with 
the element being placed.  Instead, you want the compass to maintain its 
conventional drawing plan mode of X-axis horizontal and Y-axis vertical.  In 
this case, press V on the keyboard to rotate the compass back to the “view” 
plane. 

Note: When using AccuDraw with the SmartLine command, there is a 
SmartLine Placement Settings (select the  arrow) called Rotate 
AccuDraw to Segments.  Toggle this option off if you always 
want the AccuDraw compass to maintain its conventional 
drawing plane mode of X-axis horizontal and Y-axis vertical. 

The AccuDraw keyboard shortcut V will always rotate the compass to the view 
in which you’re placing elements.  Therefore, in a 3D file, pressing V in a front 
view, rotates the AccuDraw compass so that the X-axis is horizontal in the front 
view; whereas pressing V in a top view rotates the compass so that the X-axis is 
horizontal in the top view.  Or, you can quickly rotate the compass to a 
particular view by pressing the appropriate keyboard shortcut below: 

 T – top view 
 F – front view 
 S – side view 

                  

 

                      

 

                   

 

Compass Compass 
rotated to Front 

Compass 
rotated to Top 

Compass 
rotated to Front 

Compass 
rotated to Top 

Compass 
rotated to Front 

Top View 

Front View 

Side View 

Compass 
rotated to Side 
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Using these keyboard shortcuts simplifies drawing in 3D.  For civil design 
applications, however, most of the time you will be drawing in a top (plan) 
view. 

Another handy rotation option is Rotate Quick (keyboard shortcut <R> <Q>). 
This temporarily rotates the compass dynamically as you move your pointer.  
This is handy to rotate the AccuDraw compass to match the angle of an existing 
element to place off of that element or when placing cells or text. 

AccuDraw, Tentative Points and the AccuDraw Origin 
When you tentative snap to an existing element, press O on the keyboard to 
move the AccuDraw origin temporarily to the tentative location.  You can then 
locate the AccuDraw compass off of this tentative point by entering values in 
the AccuDraw window.  If you accept the tentative with a data point, you 
compass “sticks” in this location. 
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AccuDraw Keyboard Shortcuts 

Key Effect 

<Enter> 

Smart Lock 

• In Rectangular coordinates, locks X to 0 if the pointer is on the drawing plane y-axis 
or Y to 0 if the pointer is on the x-axis. 

• In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer is on a 
drawing plane axis or otherwise locks Distance to its last entered value. 

<Space bar> Switches between Rectangular and Polar coordinates. 
<O> Moves the drawing plane origin to the current pointer position. 
<V> Rotates the drawing plane to align with the view.  

<T> Rotates the drawing plane to align with the axes in a standard. 
<F> Rotates the drawing plane to align with the axes in a standard Front view. 
<S> Rotates the drawing plane to align with the axes in a standard Side view. 

<B> 
Rotates the drawing plane to align with the active ACS, or if you set up a rotation in the 
dialog, it will return you to that rotation. In a new file (where you haven't used an ACS yet) it 
will be the rotation of the view. 

<E> 
Rotates between three main planes: top, front, and side (3D only). This also works when your 
original plane is an ACS or context rotation, so you do not have to use RX, RY to rotate to a 
90° plane. 

<X> Toggles the lock status for the X value. 
<Y> Toggles the lock status for the Y value. 
<Z> Toggles the lock status for the Z value. 

<D> Toggles the lock status for the Distance value. 
<A> Toggles the lock status for the Angle value. 

<L> 

Locks the current index state. If an axis or distance is not indexed, indexing is disabled. On 
the other hand, if an axis or distance is indexed, it is locked. The effect is temporary, lasting 
until a data point is entered or the shortcut is run again. This is useful if you need to index to 
one axis but not the other, or to enter a data point very close to an axis but not on the axis. 

<R>,<Q> Used to quickly and temporarily rotate the drawing plane. 

<R>,<A> 

Used to permanently rotate the drawing plane. Because it rotates the current ACS, this 
rotation will still be active after the tool in use is exited. If on, the tool setting Use Current 
Origin causes the drawing plane origin to be used as the x-axis origin, thereby eliminating the 
need to enter an extra data point. Of course, in many cases it is desirable to be able to define 
the x-axis origin at a different location than the drawing plane origin. 

<R>,<X> Rotates the drawing plane 90° about its x-axis. 

<R>,<Y> Rotates the drawing plane 90° about its y-axis. 

<R>,<Z> Rotates the drawing plane 90° about its z-axis. 
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AccuDraw Keyboard Shortcuts (cont’d) 

Key Effect 
<?> Opens the AccuDraw Shortcuts window. 

<~> 

Bumps an item in the tool settings dialog box (shortcut is ~, usually right under the <Esc> 
key — there is no need to press the <Shift> key). It finds the first enabled item in the tool 
settings dialog box that is a toggle button or an option button, and either toggles it or bumps 
it to the next valid value. For instance, if you are drawing a SmartLine and the focus is in the 
AccuDraw window, you can just press the <~> key and it switches to arcs without moving 
the focus from the AccuDraw window. 

Key-in: ACCUDRAW BUMP TOOLSETTING. 

<G>,<T> Moves focus to the Tool Settings window. 

<G>,<K> Opens (or moves focus to) the Key-in window. 

<G>,<S> Opens (or moves focus to) the AccuDraw Settings dialog box (same as choosing AccuDraw 
from the Settings menu). 

<G>,<A> Opens the Get ACS dialog box, which lets you select a saved Auxiliary Coordinate System. 

<W>,<A> Opens the Write to ACS dialog box, which lets you save the drawing plane alignment as an 
ACS. 

<P> Opens the Data Point Key-in dialog box for entering a single data point. 

<M> Opens the Data Point Key-in dialog box for entering multiple data points. 

<I> Activates Intersect snap mode. 

<N> Activates Nearest snap mode. 

<C> Activates Center snap mode. 

<K> Opens the Keypoint Snap Divisor dialog box, which is used to set the Snap Divisor for 
keypoint snapping. 

<U> Suspends AccuSnap for the current tool operation. Selecting a new tool, or entering a Reset 
re-enables AccuSnap. 

<J> Toggles AccuSnap. 

<Q> Deactivates AccuDraw. 

1.  Source: Bentley Systems on-line Users Guide, Working with AccuDraw. 
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Tips 
 Use <Page Up> and <Page Down> to recall AccuDraw entries. 
 AccuDraw has a built-in pop-up calculator in all of the AccuDraw 

window fields.  Entering an arithmetic (+, -, *, /or =) key automatically 
activates the calculator.  Use the = key to replace the current value and 
enter new values into the pop-up calculator. 

 

 AccuDraw “remembers” your last X,Y or Distance value.  To place the 
next data point using the same value, simply drag your pointer until you 
see the “tick” mark that indicates the last entry value.  This saves you 
from repeatedly keying in the same value. 

 

 

Last distance 
tick mark 



Colorado Department of Transportation 

 
 

Page 206  Bentley Redline Essentials 

Exercise 1 – Precision Placement with AccuDraw 

Objectives 
After completing this exercise you will know how to: 

 Locate a delta distance from a tentative point using AccuDraw. 
 Place lines, arcs and blocks using AccuDraw’s rectangular compass. 
 Place lines, arcs and blocks using AccuDraw’s polar compass. 
 Use SmartLine to create a complex shape and a complex chain of lines 

and arcs. 

Utilizing AccuDraw 

Open the Design File 
1. Start Redline and open 12345DES_PnP02.dgn from the 

C:\Projects\12345\Design\Drawings\ folder. 

As-Built the Median Island Nose Change using AccuDraw 
In the next series of steps, you’ll draw the Median Island. 
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Check Design File Settings 

Set Coordinate Readout Values 

2. Open the DGN File Settings box from Settings > Design File. 

3. Select the Coordinate Readout category and change the angle 
mode to Conventional as shown. 

 

When drawing details later in this lab, you’ll enter your angles in 
conventional mode instead of Bearing. 

4. Select OK to apply the new parameters.  

5. Save your design file settings by choosing File > Save Settings. 

Note:  You can also key in File to save settings. 

When you next enter this design file, your settings (working units, 
coordinate readout, etc.) will be just as you have now saved them. 
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6. Window into the area approximately as shown. 

 

Window in here
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Draw Median Using AccuDraw 
7. Activate the CDOT Menu from the Main Tool frame if it isn’t 

already activated. 

8. From the CDOT Menu, select the Show Lines filter. 

9. Then select the Linework item. 

The Place SmartLine command is selected. 

 

10. Set the Settings options as shown. 

 

11. Verify that AccuDraw is toggled on and is in Rectangular mode. 

 

12. <D> at an empty area in the view window to start the line. 

13. Nudge your pointer to the left using the on-the-fly horizontal axis, 
and then type 25. 

This automatically locks the X value in the AccuDraw window. 

14. The Y value in the AccuDraw window should read out 0.000. 

  

15. <D> to place the point. DO NOT reset the command. 

16. In SmartLine’s Tool Settings set Segment Type to Arcs 
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Redline now prompts you to enter the center of the arc. 

17. Nudge your pointer down using the on-the-fly vertical axis. 

Note: This sets the focus (the blinking cursor) in the AccuDraw 
window to the Y axis field. 

18. In AccuDraw’s window, key in a Y value of 6.333. 

 

19. With your pointer locked in on the Y axis, <D> to define the arc’s 
center point. 

Redline now prompts you to enter the sweep angle.  The AccuDraw 
compass automatically changes to polar mode. 

20. Swing your pointer to the left 180 degrees and lock in on the Y 
axis again and <D> to define the sweep angle. 

 

21. In Tool Settings, set Segment Type back to Lines. 
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22. Press <spacebar> to switch the AccuDraw window and compass 
back to rectangular mode. 

 

23. Nudge your pointer to the right using the on-the-fly horizontal axis. 

24. Press <Enter> to Smart Lock AccuDraw.  The Y and Z fields will 
be locked. 

  

25. Hover the pointer over the original starting point to allow 
AccuSnap to identify the location.  The X field in the AccuDraw 
window will populate with the parallel distance. 

 

26. <D> to accept the length. 

27. AccuSnap again to the first point to complete the shape. 
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Note: Notice the change in the Tool Settings dialog; these are 
additional settings for closed elements that the SmartLine 
command is capable of creating.  Instead of creating the 
individual lines and arc, SmartLine allows you to create these 
elements all in one step.  Also, by AccuSnapping to the first 
point, the SmartLine command automatically converts the 
elements to a complex shape. 

28. While still in the Place SmartLine command, <T> (tentative snap) 
to the upper right corner of the outside edge.  A large cross hair 
symbol will appear at the identified location. 

 

29. With focus in the AccuDraw dialog use the origin key-in O.  This 
will place the origin of AccuDraw compass at the upper right 
corner of the detail. 

 

30. Nudge your pointer down using the on-the-fly vertical axis then 
press the <Enter> key to activate Smart Lock. 

31. With the vertical axis locked enter a value of 1. 

 

32. <D> to accept the new origin point.  The AccuDraw compass will 
have moved 1 foot in the Y direction. 

What we have done is defined the starting location of the new linestring 
with out the use of any construction elements. 

33. Nudge your pointer to the left using the on-the-fly horizontal axis, 
activate Smart Lock, and then type 25. 
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This automatically locks the X value in the AccuDraw window.  The Y 
value in the AccuDraw window should be reading 0.000. 

 

34. <D> to place the point. 

35. In SmartLine’s Tool Settings and set Segment Type to Arcs. 

 

Redline now prompts you to enter the center of the arc. 

36. Nudge your pointer down using the on-the-fly vertical axis. 

37. In AccuDraw’s window, key in a Y value of 5.333 (the arc’s 
radius).   

 

38. With your pointer locked in on the Y axis, <D> to define the arc’s 
center point. 

39. Swing your pointer to the left 180 degrees to lock in on the Y axis 
and <D> to define the sweep angle. 
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40. In Tool Settings, set Segment Type back to Lines. 

 

41. Press <spacebar> to switch the AccuDraw window and compass 
back to rectangular mode. 

 

42. Nudge your pointer to the right using the on-the-fly horizontal axis. 

43. Press <Enter> to Smart Lock AccuDraw.  The Y and Z fields will 
be locked. 

44. AccuSnap to the bottom right corner of the detail, the X field will 
populate with the parallel distance. 

 

45. <D> to place the point. 

Draw the median cover 

46. Select the Place Block command and set the options as shown. 

  

47. <T> to the upper right corner of the outside edge.  A large cross 
hair symbol will appear at the identified location. 
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48. With focus in the AccuDraw dialog use the origin key-in O.  This 
will place the origin of AccuDraw compass at the upper right 
corner of the detail. 

 

49. Nudge your pointer down using the on-the-fly vertical axis then 
press the <Enter> key to activate Smart Lock. 

50. With the vertical axis locked key-in a value of 1.8333. 

 

51. <D> to accept the new origin point.  The AccuDraw compass will 
have moved 1.8333 feet in the Y direction. 

What we have done is defined the starting location of the new block with 
out the use of any construction elements. 

52. Nudge your pointer to the left using the on-the-fly horizontal axis, 
and then type 5.  DO NOT accept the command. 

This automatically locks the X value in the AccuDraw window. 
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53. Nudge your pointer down using the on-the-fly vertical axis, and 
then type 9. 

This automatically locks the Y value in the AccuDraw window. 

 

54. <D> to accept the placement of the block. 

 

55. Fit View 1. 

56. File > Save Settings. 

57. Choose File > Exit to exit Redline and your design file. 
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Appendix C 

Patterning & Hatching 
You may have a need to pattern areas on your plan sheet with a hatch or 
crosshatch.   

CDOT Menu Pattern 
Two pattern types are available in Redline, they are Hatch and Cross Hatch.  A 
hatch pattern is one line placed by an offset spacing and angle.  A cross hatch 
pattern is two lines placed by an offset spacing and angle.   

By selecting the Show Pattern icon in the CDOT Menu the two hatches will 
appear.  Tool settings and methods for the two hatches are defined next. 
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Hatch Toolbar 

 

The Hatch toolbar contains tools for hatching and cross-hatching shapes or 
areas.  You can also pattern any line, shape or area with a cell.  The Hatch tools 
include: 

Hatch and Crosshatch Area 
Hatches are closed shapes or an area in the active model or a reference.  Set the 
Spacing (in master units) and Angle of the hatch line and turn on Snappable 
Pattern if you later want to snap to the pattern graphics (the hatch lines in this 
case).  If you’re patterning curved element, key in a Tolerance or minimum 
distance for chording off the pattern around the curve. 

   

Toggle on Associative Patterning if you want the pattern to update if the 
element is modified.  In addition, broken patterns can be re-associated by re-
connecting the pattern shapes. 

Toggle on Associative Region Boundary to place the pattern on a different 
level from the patterned element. 
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Choose the Show Extended Settings arrow to select the Use Element 
Symbology option, which allows you to place elements with the same 
symbology as the element being patterned. 

 

The icon bar at the top of the dialog box allows you to select the pattern method 
(how the area will be patterned), which includes: 

 Element —a closed shape.  
 Flood — the area enclosed by a set of elements.  
 Union — area defined by the union of two or more closed shapes. 
 Intersection — area defined by the intersection between two or more 

closed shapes. 
 Difference — area defined by the difference between two or more closed 

shapes. 
 Points — an area defined by a series of data points where you 

dynamically define an area.  
 Fence — the area inside the fence. 
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With the Flood method, select the Show Extended Information arrow for more 
icon bar options including: 

 

 Ignore Interior Shapes – patterns through any shapes located inside the 
pattern area. 

 Locate Interior Shapes — excludes patterning of shapes located inside 
the pattern area. 

 Identify Alternating Interior Shapes – alternating areas are patterned 
where shapes are nested inside one another. 

 Locate Text — patterns around any text inside or overlapping the pattern 
area. 

 Dynamic Area — provides a preview of what area will be hatched or 
patterned before actually patterning. 

 Max gap – enter the maximum distance, in working units, between 
endpoints that make up the flooded region.  If the distance is greater than 
that specified, the element will not be included in the flooded region. 

 Text margin – when locating text, specify the “clear area” margin, in 
working units around the text.  This area will not be patterned. 

If Associative Pattern is turned on, patterns will dynamically update 
when associated elements (text, interior shapes) are moved or modified. 
Be sure to turn on Associative Region Boundary and the Association 
lock for this to work.  

With the Flood, Union, Difference and Intersection methods, the 
Associative Region Boundary option creates a complex shape that is 
associated to the pattern graphics.  This shape can also be moved or 
modified to update the pattern graphics.  Also, turn on this option when 
locating text, to eliminate the text boundary box. 

Icon Bar 
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Delete Hatch 
Although similar to the delete element icon, this command will only locate and 
delete hatches and cross hatches. 

 

 Select the Delete Hatch icon 
 Identify the pattern 
 Accept the deletion 
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Appendix D 

Quicksets 
Quicksets let you save selected elements for later recall.  You can create and 
recall up to ten named groups with the Quickset Save and Quickset Recall 
menus. 

 

Quicksets are given the names Quickset0 through to Quickset9. If you prefer, 
you can use the Named Groups dialog box to rename them.  However, you’ll 
no longer have access to them via the Quickset Save and Quickset Recall 
menus. 

 

 

 

To create a quickset using the pop-up menu: 

 Create a selection set.  
 Press <Shift> + <R>, to open the view pop-up menu. 
 Choose Quickset > Save and the quickset number. 

To recall a quickset using the pop-up menu: 

 Press <Shift> + <R>, to open the view pop-up menu. 
 Choose Quickset > Recall and the quickset number. 

The previously saved selection set is re-activated. 



 Appendix D – Quicksets 

 

Bentley Redline Essentials  Page 223 

To create a quickset using a keyboard shortcut: 

 Create a selection set. 
 Press <Ctrl + Shift + n> where “n” is the number of the quickset. 

Note: “n” must be from 0 to 9 and entered from the alphanumeric part 
of the keyboard (not the keypad). 

 

To recall a quickset with a keyboard shortcut: 

Press <Ctrl + n> where “n” is the number of the quickset that you want to recall.  

Note: “n” must be from 0 to 9 and entered from the alphanumeric part 
of the keyboard (not the keypad). 

  

To rename a quickset to a named group 

 Select Add to Graphic Group from the Groups toolbar. 
 Select Open Named Group Dialog. 
 In the Named Groups dialog box, select the named group. 
 Click into the name field and rename the quickset. 

Note:  After renaming, you’ll no longer be able to recall the quick set 
via the pop-up menu. 
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Appendix E 

Displaysets 
Displaysets let you select a group of elements to display in a selected view while 
hiding all other elements in a view. You can create Displaysets from selection 
sets or named groups.  

 

To use Displaysets, you must have Displayset toggled on in View Attributes. 

 

To create a displayset from selected elements: 

 Create a selection set. 
 Press <Shift> + <R>, to open the view pop-up menu. 
 Choose Displayset>Set. 

Only the Displayset elements are displayed in the view. All other elements are 
hidden. 
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To select a named group as the displayset 

 Select Add to Graphic Group from the Groups toolbar. 
 Select Open Named Group dialog. 
 In the Named Groups dialog box, select the named group. 
 Select Put Elements into the Displayset icon. 

  All elements from the named group go into the active displayset 
and all other elements are hidden. 

 

To clear a displayset: 

 Press <Shift> + <R>, to open the view pop-up menu. 
 Choose Displayset>Clear. 

  The displayset is cleared and all elements are shown in the view. 
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Appendix F 

Preferences 

Setting Views for Dual Monitors 
Redline allows the use of dual monitors, but you must follow this procedure to 
configure them the first time they are used. 

 Start Redline. 
 Select Workspace > Preferences > Operation and toggle on Open 

Two Application Windows. 

 

 Select File > Save Settings. 
 Exit, and then restart Redline. 

When Redline starts this time, it will open two different windows.   

 

You can drag one window to the other monitor.  (Click on the title bar and drag 
the window– don’t stretch it).  When you maximize the window, it will fill the 
screen on the monitor where you placed it rather than span both monitors.  In 
Redline, Views 1-4 open in application window 1, while Views 5-8 open in 
application window 2. 

You can drag most Redline windows from one monitor to the other, but there 
are some that will not allow dragging.  If you run into one, pick the Bentley logo 
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in the upper left corner and choose Change Screen to move the dialog or menu 
to the other screen. 

 

Wheel Mouse Settings 
Redline supports wheel mice.  You can set your middle wheel to perform several 
different view control options including Zoom In/out, pan radial, and pan with 
zoom. Select Workspace > Preferences > Mouse to configure the wheel on 
your mouse. 

Change the wheel settings 

1. From the drop-down menu select Workspace > Preferences.  

2. On the left side of the dialog, select Mouse from the Category list. 

3. Set the Wheel to Pan Left/Right. 

 

4. Select OK to accept the changes and close the dialog box. 
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5. Move your mouse wheel back and forth to pan in the view. 

Note: You can also Pan by selecting this command on the View 
Control toolbar.  Specify a “from” and “to” point to move in the 
view. 

     

6. Set your wheel for the view control option you prefer (Workspace 
> Preferences > Mouse). 

 

Use the wheel on the mouse to Zoom In/Out 

7. Roll the wheel up;  this zooms in on your graphics. 

8. Roll the wheel back;  this zooms out. 

Note: If you <T> on a location before rolling the wheel, that location 
will center in the view when the wheel is rolled. 

 

Tool Settings 
for Pan View 
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Appendix G 

Directory Structure 
1. From the CDOT Menu, select Help > Workflows. 

 

This will launch the CDOT internal site.  From there, a workflow on the 
complete directory structure can be accessed, called CDOT Directory Structure.  
This workflow can also be accessed from the CADD Manual. 

 
 



Colorado Department of Transportation 

 
 

Page 230  Bentley Redline Essentials 

Appendix H 

Annotation Scale 
Before placing text, check the Annotation Scale for text under Model 
Properties.  The Annotation Scale is set to 100, by default, in the CDOT seed 
file.  This should be the same as your plot scale.  If you’re plotting at any other 
scale, change the Annotation Scale here.  Any text that you’ve previously placed 
will be updated (e.g. you don’t have to delete and replace the text – it will be re-
scaled automatically). 
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Note: To enable scaling of text, make sure that the Annotation Scale 
lock is turned on for the Place Text command before placing 
your text.  By default, the Annotation Scale is on. 

 

Note: The Annotation Scale lock can be turned on from the status bar 
by selecting the Locks option. 
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